Zoom SDK IONIC 3

Hi,

We are implementing the Zoom SDK in to ionic 3.9.2.

We have faced zoom initialize issue.

Please find the screen shot.zoom-ionic-issue

Hi zoom2,
Thanks for the post. This is a common questions being asked online. It seems like you are having Angular Core: 5.0.0, the following might be helpful(https://forum.ionicframework.com/t/typeerror-object-is-not-a-function/130589/6):

I was also getting the same error for last two days and finally i caught the culprit.

This error started showing after upgrading the AngularFire2 to 5.0.0-rc.8 or higher and the reason is
rxjs 5 is no longer supported in AngularFire2 5.0.0-rc.8 or higher, upgrade to 6 and include rxjs-compat

npm i rxjs@^6.0 rxjs-compat

Hope this helps. Thanks!

Hi,

I has upgrade the rxjs and rxjs-compat, but issue not fixed.

Please give the solutions for zoom initialize issue.

Please find the screen shot.

Hi,
Thanks for the post. I will pass this info to our engineer and get back to you as soon as possible.

Thanks!

could you please help us in update the status of above query . Thanks

We have tested your Zoom Ionic Software Development Kit (SDK), but it’s throwing same zoom initialization issue.


Hi,
Thanks for the reply. I have past your info to our engineers. We have very limited resource on this project(This is a community project) so we might need some time to troubleshoot this. I will get back to you as soon as possible.

Thanks!

Thanks Carson .Looking forward . We have delivery deadline . Thanks for your support so far .

Hi Carson - Just checking if there are any updates on troubleshooting this. we are missing our deadline .

Thanks!

Hi zoom2,

Thanks for your reply and pardon the waiting. The engineering team is working on this and expecting to have a result recently. BTW, is using Ionic 4 an option for your project?

Thanks for your reply. We started with ionic 5 and end up in issue .Already we have discussed about this same point and came to conclusion that ionic SDK is designed for Ionic 3 or earlier". Now you suggesting ionic 4 . will its support zoom sdk ?

Please clarify asap

Please check your below forum link.

Link is: Zoom in Ionic Framework

Hi zoom2,

Thank you very much for your reply and thank you very much for your patience.

After investigating this issue, we found out that our SDK does not work with Ionic 3.9.2 anymore. We got the same error as you show to us in the screenshot and we are still trying to fix this issue. We did not make any changes on our side, the reason why it is not working is the mixed version of dependencies changed in the Ionic framework.

To save your time, we also tested our Ionic SDK with the latest Ionic framework(Ionic framework 4.6, Ionic CLI 5.2.0), and it works! If using this version is an option for your project, you may have a try and let us know.

Below is the ionic info that we got the SDK working:

Ionic:

   Ionic CLI                     : 5.2.0 (/usr/local/lib/node_modules/ionic)
   Ionic Framework               : @ionic/angular 4.6.0
   @angular-devkit/build-angular : 0.13.9
   @angular-devkit/schematics    : 7.3.9
   @angular/cli                  : 7.3.9
   @ionic/angular-toolkit        : 1.5.1

Cordova:

   Cordova CLI       : 8.1.2 (cordova-lib@8.1.1)
   Cordova Platforms : android 7.1.4
   Cordova Plugins   : cordova-plugin-ionic-keyboard 2.1.3, cordova-plugin-ionic-webview 4.1.1, (and 4 other plugins)

Utility:

   cordova-res : 0.5.1
   native-run  : 0.2.7

System:

   ios-deploy : 1.9.4
   NodeJS     : v8.12.0 (/usr/local/bin/node)
   npm        : 6.7.0
   OS         : macOS Mojave
   Xcode      : Xcode 10.2.1 Build version 10E1001

And below is the dependencies in package.json that we got the SDK working:

"dependencies": {
    "@angular/common": "^7.2.2",
    "@angular/core": "^7.2.2",
    "@angular/forms": "^7.2.2",
    "@angular/http": "^7.2.2",
    "@angular/platform-browser": "^7.2.2",
    "@angular/platform-browser-dynamic": "^7.2.2",
    "@angular/router": "^7.2.2",
    "@ionic-native/core": "^5.8.0",
    "@ionic-native/splash-screen": "^5.0.0",
    "@ionic-native/status-bar": "^5.0.0",
    "@ionic-native/zoom": "^5.8.0",
    "@ionic/angular": "^4.1.0",
    "cordova-android": "7.1.4",
    "cordova-plugin-device": "^2.0.2",
    "cordova-plugin-ionic-keyboard": "^2.1.3",
    "cordova-plugin-ionic-webview": "^4.1.1",
    "cordova-plugin-splashscreen": "^5.0.2",
    "cordova-plugin-statusbar": "^2.4.2",
    "cordova-plugin-whitelist": "^1.3.3",
    "cordova.plugin.zoom": "^4.3.9440-1.325",
    "core-js": "^2.5.4",
    "rxjs": "~6.5.1",
    "tslib": "^1.9.0",
    "zone.js": "~0.8.29"
  },
  "devDependencies": {
    "@angular-devkit/architect": "~0.13.8",
    "@angular-devkit/build-angular": "~0.13.8",
    "@angular-devkit/core": "~7.3.8",
    "@angular-devkit/schematics": "~7.3.8",
    "@angular/cli": "~7.3.8",
    "@angular/compiler": "~7.2.2",
    "@angular/compiler-cli": "~7.2.2",
    "@angular/language-service": "~7.2.2",
    "@ionic/angular-toolkit": "~1.5.1",
    "@types/node": "~12.0.0",
    "@types/jasmine": "~2.8.8",
    "@types/jasminewd2": "~2.0.3",
    "codelyzer": "~4.5.0",
    "jasmine-core": "~2.99.1",
    "jasmine-spec-reporter": "~4.2.1",
    "karma": "~4.1.0",
    "karma-chrome-launcher": "~2.2.0",
    "karma-coverage-istanbul-reporter": "~2.0.1",
    "karma-jasmine": "~1.1.2",
    "karma-jasmine-html-reporter": "^0.2.2",
    "protractor": "~5.4.0",
    "ts-node": "~8.3.0",
    "tslint": "~5.17.0",
    "typescript": "~3.1.6"
  },

Sorry for the wait and we truely hope this would be helpful. If using the above version is not an option for your project, I will keep you updated with our findings on the errors you have in the screenshot.

Thanks!