Zoom SDK IONIC 3

could you please help us in update the status of above query . Thanks

We have tested your Zoom Ionic Software Development Kit (SDK), but it’s throwing same zoom initialization issue.


Hi,
Thanks for the reply. I have past your info to our engineers. We have very limited resource on this project(This is a community project) so we might need some time to troubleshoot this. I will get back to you as soon as possible.

Thanks!

Thanks Carson .Looking forward . We have delivery deadline . Thanks for your support so far .

Hi Carson - Just checking if there are any updates on troubleshooting this. we are missing our deadline .

Thanks!

Hi zoom2,

Thanks for your reply and pardon the waiting. The engineering team is working on this and expecting to have a result recently. BTW, is using Ionic 4 an option for your project?

Thanks for your reply. We started with ionic 5 and end up in issue .Already we have discussed about this same point and came to conclusion that ionic SDK is designed for Ionic 3 or earlier". Now you suggesting ionic 4 . will its support zoom sdk ?

Please clarify asap

Please check your below forum link.

Link is: Zoom in Ionic Framework - #8 by Carson_Chen

Hi zoom2,

Thank you very much for your reply and thank you very much for your patience.

After investigating this issue, we found out that our SDK does not work with Ionic 3.9.2 anymore. We got the same error as you show to us in the screenshot and we are still trying to fix this issue. We did not make any changes on our side, the reason why it is not working is the mixed version of dependencies changed in the Ionic framework.

To save your time, we also tested our Ionic SDK with the latest Ionic framework(Ionic framework 4.6, Ionic CLI 5.2.0), and it works! If using this version is an option for your project, you may have a try and let us know.

Below is the ionic info that we got the SDK working:

Ionic:

   Ionic CLI                     : 5.2.0 (/usr/local/lib/node_modules/ionic)
   Ionic Framework               : @ionic/angular 4.6.0
   @angular-devkit/build-angular : 0.13.9
   @angular-devkit/schematics    : 7.3.9
   @angular/cli                  : 7.3.9
   @ionic/angular-toolkit        : 1.5.1

Cordova:

   Cordova CLI       : 8.1.2 (cordova-lib@8.1.1)
   Cordova Platforms : android 7.1.4
   Cordova Plugins   : cordova-plugin-ionic-keyboard 2.1.3, cordova-plugin-ionic-webview 4.1.1, (and 4 other plugins)

Utility:

   cordova-res : 0.5.1
   native-run  : 0.2.7

System:

   ios-deploy : 1.9.4
   NodeJS     : v8.12.0 (/usr/local/bin/node)
   npm        : 6.7.0
   OS         : macOS Mojave
   Xcode      : Xcode 10.2.1 Build version 10E1001

And below is the dependencies in package.json that we got the SDK working:

"dependencies": {
    "@angular/common": "^7.2.2",
    "@angular/core": "^7.2.2",
    "@angular/forms": "^7.2.2",
    "@angular/http": "^7.2.2",
    "@angular/platform-browser": "^7.2.2",
    "@angular/platform-browser-dynamic": "^7.2.2",
    "@angular/router": "^7.2.2",
    "@ionic-native/core": "^5.8.0",
    "@ionic-native/splash-screen": "^5.0.0",
    "@ionic-native/status-bar": "^5.0.0",
    "@ionic-native/zoom": "^5.8.0",
    "@ionic/angular": "^4.1.0",
    "cordova-android": "7.1.4",
    "cordova-plugin-device": "^2.0.2",
    "cordova-plugin-ionic-keyboard": "^2.1.3",
    "cordova-plugin-ionic-webview": "^4.1.1",
    "cordova-plugin-splashscreen": "^5.0.2",
    "cordova-plugin-statusbar": "^2.4.2",
    "cordova-plugin-whitelist": "^1.3.3",
    "cordova.plugin.zoom": "^4.3.9440-1.325",
    "core-js": "^2.5.4",
    "rxjs": "~6.5.1",
    "tslib": "^1.9.0",
    "zone.js": "~0.8.29"
  },
  "devDependencies": {
    "@angular-devkit/architect": "~0.13.8",
    "@angular-devkit/build-angular": "~0.13.8",
    "@angular-devkit/core": "~7.3.8",
    "@angular-devkit/schematics": "~7.3.8",
    "@angular/cli": "~7.3.8",
    "@angular/compiler": "~7.2.2",
    "@angular/compiler-cli": "~7.2.2",
    "@angular/language-service": "~7.2.2",
    "@ionic/angular-toolkit": "~1.5.1",
    "@types/node": "~12.0.0",
    "@types/jasmine": "~2.8.8",
    "@types/jasminewd2": "~2.0.3",
    "codelyzer": "~4.5.0",
    "jasmine-core": "~2.99.1",
    "jasmine-spec-reporter": "~4.2.1",
    "karma": "~4.1.0",
    "karma-chrome-launcher": "~2.2.0",
    "karma-coverage-istanbul-reporter": "~2.0.1",
    "karma-jasmine": "~1.1.2",
    "karma-jasmine-html-reporter": "^0.2.2",
    "protractor": "~5.4.0",
    "ts-node": "~8.3.0",
    "tslint": "~5.17.0",
    "typescript": "~3.1.6"
  },

Sorry for the wait and we truely hope this would be helpful. If using the above version is not an option for your project, I will keep you updated with our findings on the errors you have in the screenshot.

Thanks!

Hi I have the same problem, here’s my ionic info:

Ionic:

   Ionic CLI          : 5.4.16 (C:\Users\johnt\AppData\Roaming\npm\node_modules\ionic)
   Ionic Framework    : ionic-angular 3.9.9
   @ionic/app-scripts : 3.2.4

Cordova:

   Cordova CLI       : 9.0.0 (cordova-lib@9.0.1)
   Cordova Platforms : android 8.1.0
   Cordova Plugins   : cordova-plugin-ionic-keyboard 2.2.0, cordova-plugin-ionic-webview 4.1.3, (and 4 other plugins)

Utility:

   cordova-res : not installed
   native-run  : 0.3.0

System:

   Android SDK Tools : 26.1.1 (C:\Users\johnt\AppData\Local\Android\Sdk)
   NodeJS            : v12.16.1 (C:\Program Files\nodejs\node.exe)
   npm               : 6.13.4
   OS                : Windows 10

and my packet.json:

  "dependencies": {
    "@angular/animations": "5.2.11",
    "@angular/common": "5.2.11",
    "@angular/compiler": "5.2.11",
    "@angular/compiler-cli": "^9.0.7",
    "@angular/core": "5.2.11",
    "@angular/forms": "5.2.11",
    "@angular/platform-browser": "5.2.11",
    "@angular/platform-browser-dynamic": "5.2.11",
    "@ionic-native/core": "4.20.0",
    "@ionic-native/splash-screen": "4.20.0",
    "@ionic-native/status-bar": "4.20.0",
    "@ionic-native/zoom": "^5.22.0",
    "@ionic/storage": "2.2.0",
    "cordova-android": "8.1.0",
    "cordova-res": "^0.10.0",
    "cordova.plugin.zoom": "^4.4.5513-0.712",
    "ionic-angular": "3.9.9",
    "ionicons": "3.0.0",
    "rxjs": "^6.0.0",
    "rxjs-compat": "^6.5.4",
    "sw-toolbox": "3.6.0",
    "zone.js": "0.8.29"
  },
  "devDependencies": {
    "@ionic/app-scripts": "3.2.4",
    "cordova-plugin-device": "^2.0.2",
    "cordova-plugin-ionic-keyboard": "^2.2.0",
    "cordova-plugin-ionic-webview": "^4.1.3",
    "cordova-plugin-splashscreen": "^5.0.2",
    "cordova-plugin-statusbar": "^2.4.2",
    "cordova-plugin-whitelist": "^1.3.3",
    "typescript": "2.6.2"
  },
  "description": "An Ionic project",
  "cordova": {
    "plugins": {
      "cordova-plugin-whitelist": {},
      "cordova-plugin-statusbar": {},
      "cordova-plugin-device": {},
      "cordova-plugin-splashscreen": {},
      "cordova-plugin-ionic-webview": {
        "ANDROID_SUPPORT_ANNOTATIONS_VERSION": "27.+"
      },
      "cordova-plugin-ionic-keyboard": {},
      "cordova.plugin.zoom": {}
    },
    "platforms": [
      "android"
    ]
  }

Hi johntyty2,

Thanks for the information. Are you facing the initialization issue as mentioned in the first post?

Yes, Carson_Chen.

Hi johntyty2,

Thanks for confirming this. I have forwarded this to the engineering team for investigation and will get back to you shortly.

i am facing issue in ionic 3 version.

when i am import { Zoom } from ‘@ionic-native/zoom’;

then geting issue

any

‘Zoom’ refers to a value, but is being used as a type here.ts

Hi praveen.tripathi,

Thanks for using Zoom SDK. Maybe the following link could be helpful for the issue you are facing: https://stackoverflow.com/questions/55997831/why-am-i-getting-an-error-that-some-ionic-components-are-referring-to-a-value-bu

Thanks!

Yes but when I am writing /ngx then function is not defined.

Hi praveen.tripathi,

Thanks for the reply. It should be there, our Ionic SDK demo app is also using /ngx:https://github.com/zoom/sample-app-ionic/blob/master/src/app/app.component.ts#L6, could you refer to the implementation of the demo app and see it helps?

Thanks!

I am also facing the initialization issue. Please resolve it asap

Ionic Info

Ionic:

   Ionic CLI          : 5.4.16
   Ionic Framework    : ionic-angular 3.9.9
   @ionic/app-scripts : 3.2.4

Cordova:

   Cordova CLI       : 9.0.0 (cordova-lib@9.0.1)
   Cordova Platforms : android 8.1.0
   Cordova Plugins   : cordova-plugin-ionic-keyboard 2.0.5, cordova-plugin-ionic-webview 1.1.1, (and 7 other plugins)

Utility:

   cordova-res : 0.11.0
   native-run  : 1.0.0

System:

   NodeJS : v12.16.1 (C:\Program Files\nodejs\node.exe)
   npm    : 6.13.4
   OS     : Windows 10

Hi,

Thanks for the reply. I see you have the same question in Cannot run sample ionic app, I will provide further assistance over there.

Thanks!

I’m also facing the initialization issue. Please resolve it asap

Hi @carson.zoom how are you? just want to ask an update regarding initialization issue faced by @rachanasingh102 and others.
Thank you very much