ZR CSAPI - joining a meeting multishare not enabled?

Description
Hi,

I’ve been working on a Zoom Rooms system for a client with the CLI api. The system’s primary use case is very out of the ordinary(three zoom rooms in the same room joining the same meeting simultaneously…). In any case, I’ve got all of the automation working, but we’ve found an issue that’s a bit of a dealbreaker for the client. We need the rooms to join and have “multiple participants can share” enabled automatically. At this point, someone needs to join the meeting from a laptop and enable it manually. We believe we have all the settings correct within their admin dashboard, because if you join that same meeting from an IPad, the setting is automatically enabled. Any thoughts?

Which App Type (OAuth / Chatbot / JWT / Webhook)?
CLI

How To Reproduce (If applicable)
Steps to reproduce the behavior:
Booking meeting on meeting list.
Join meeting with either Join or Dial command.

Thanks in advance.

Hey @alexadach,

Thank you for reaching out to the Zoom Developer Forum. When you enable this setting and see that it works on an iPad, how are you enabling the setting? My understanding is that this feature is only fully supported by desktop clients.

image

Thanks,
Max

Hi Max,

The Zoom Room System has “allow multiple participants to share by default” enabled within the Room settings on the zoom admin page.

We ran through the scenario today, just to confirm the behavior.

The end user created a meeting on their laptop through outlook. Invited the zoom room.

The zoom room recieves the booking list item, and using the API joins the call, first before the host. The other two zoom rooms join as well. Once all three are in I send start HDMI share commands to each.

Oddly enough, the first time we joined meeting ID: 95108336131 today. All three zoom rooms were sharing simultaneosly. We tried to recreate this but failed. In every other case, we need to manually enable the multishare setting from an end usered desktop client.

Hopefully that makes sense.

Alex

Hey @alexadach,

Thank you for providing additional information. I wasn’t able to confirm if this is expected or if there is something else that needs to be done in order to enable the setting automatically. I’ve since reached out to our engineering team for more insight.

I’ll keep you updated as I hear back from them. (ZOOM-247399)

Thanks,
Max