1.8.5 host taking over

I see that in the web sdk 1.8.5 that I have just installed, the host can reclaim its place. I have just tried and it still doesn’t work. Is there something specific to do for the host to become host again after they left?

Hey @carbonfreeconf,

Can you provide steps to reproduce the issue? Please include the Web SDK signature you used to rejoin the meeting as host. In the future, please fill out the post template so we have enough details to assist! :slight_smile:


Description
A clear and concise description of what the question is.

Error
The full error message or issue you are running into.

Which version?
Knowing the version can help us to identify your issue faster.

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Go to ‘…’
  2. Click on ‘…’
  3. Scroll down to ‘…’
  4. See error

Screenshots
If applicable, add screenshots to help explain your problem.

Device (please complete the following information):

  • Device: [e.g. iPhone6]
  • OS: [e.g. iOS8.1]
  • Version: [e.g. 22]
  • Browser:[e.g. Chrome]

Additional context
Add any other context about the problem here.


Thanks,
Tommy

Thanks Tommy. So what I do is that I create a meeting with the api and join with the web sdk. I have two participants. One with role=1 and one with role=0. Initially, role=1 is the host but I decide to close the tab and then after a few minutes, the role=0 participant becomes the host. And when I rejoin with role=1 to take the host place I deserve (with the signature: ), I don’t become host. I use Chrome v87.0

It’s not automatic, you will rejoin as co-host (only if you have activated that option on your account) and from there, you will have an option (button) visible on the participant panel to claim the host power back, but you have to click on it, it’s not automatic.

I did not test it, but i think if you do not allow co-host option on the account setting, you will not rejoin as a co-host (since your in meeting participant got the host power after the host left) and therefore won’t have this option displayed.

2 Likes

Oh I see. Many thanks, it works like a charm!

2 Likes

Hey @carbonfreeconf,

I’m glad to hear that @nvivot resolved your issues! If you encounter any further issues or questions, please don’t hesitate to reach out.

Thank you for the help on this @nvivot!

Thanks,
Max

1 Like