Activate pmi_password through API

Hi,
I’m trying to activate the password on a users’ PMI through the API, sending a request to https://api.zoom.us/v2/users/{userId}/settings with this content:
{
‘id’: ‘xxx@zzz.com’,
‘schedule_meeting’: {
‘force_pmi_jbh_password’: True,
‘require_password_for_pmi_meetings’: ‘all’,
‘pmi_password’: ‘654321’
}
}
The request returns with code 204 - success.
The first 2 parameters are correctly updated.
But the ‘pmi_password’ remains empty, and parameter “PMI secret code” stays disabled:

Similarly, if pmi_password is activated, I can change it but can’t deactivate it.
What am I doing wrong ?
Or is activation of pmi_password through API not possible ?

App Type: JWT
Endpoint: https://api.zoom.us/v2/users/{userId}/settings

Hey @Palaing,

Thank you for reaching out to the Zoom Developer Forum. I was able to reproduce this issue and have since reached out to our engineering team to see if they are able to provide a fix. (ZOOM-262427)

I’ll update you here when I have more information.

Thanks,
Max

Hey @Palaing,

Thank you for your patience. Our engineering team got back to me and indicated that you can use the pmi_passcode parameter to enable/disable the Personal Meeting ID (PMI) Passcode setting as the other options are being phased out and are not available for some users.

Let me know if that helps.

Thanks,
Max

Dear Max,
Thank you very much for your reply.
Still, I’m confused, as in the results of a “GET /users/{userId}/settings” request I see several parameters which name include “password”, including “pmi_password”, but nothing like “pmi_passcode”.
I also tried without success to set “pmi_passcode” in a “PATCH /users/{userId}/settings” request.
Should I look elsewhere? or what am I getting wrong?
Best regards,
Alain

Hey @Palaing,

Thank you for the update, I apologize for the confusion. I mistyped what I meant to say. When using the Update User Settings API, you’ll want to set the pmi_password field in order to enable/disable the Personal Meeting ID (PMI) Passcode setting.

image

I hope that clears things up! Let me know if you have any questions.

Thanks,
Max

Dear @MaxM,
Thank you for this clarification.
Unfortunately this brings me back to my initial question: using PATCH users/{userId}/settings,

  • I can successfully change pmi_password when the PMI passcode is activated ,
    but I can’t:
  • either set a pmi_password (with eg ‘pmi_password’: ‘654321’) when the PMI passcode is not activated,
  • or deactivate the PMI password (with ‘pmi_password’: ‘’) when it is activated.
    In each case the requests returns a success code, but the value of ‘pmi_password’ remains unchanged…
    Best regards,
    Alain

Hey @Palaing,

Thank you for testing that out and getting back to me. I’ll check in with our engineering team to see if they are able to clarify the expected behavior here.

Thanks,
Max