All passcodes changing to most recent passcode

I’m creating meetings on behalf of users in my org and setting them as the host using /users/{userId}/meetings, however we have found one issue that we cannot figure out.

For one user, his passcode for all scheduled future meetings is being changed to the most recent passcode generated through the API (which I set by creating a random 9 digit string). The scheduled meetings I am creating via /users/{userId}/meetings does not include the use_pmi=false flag, which the documentation says defaults to false. I noticed this user on the Zoom Dev forum had the same issue but nothing came of it:

There is also this setting for that specific user in his Schedule Meeting settings:

If I do not provide the use_pmi flag, does it use whatever his settings are? And if I manually set this to false in the API call, does this overwrite his settings?

This is confusing, and greatly impacts us. Any help is appreciated.

Hey @mvukojevic,

Thanks for reaching out about this, and happy to help.

As a first step, can you confirm that the passcode being set doesn’t match that of the user’s PMI password? It sounds like it’s one you’re setting, but I’d like to rule this out. When a user has these PMI settings configured, any Meetings you create via API should inherit these.

Additionally, if you could provide a copy of the request URL and body that you’re using when you experience this behavior, as well as the response, this will help me to take a closer look.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.