Generating a custom password seems to change the PMI password for the user for existing meetings

We’re using the following request to create a scheduled meeting for a user:

{"agenda":"","password":"fT!3pO*4qS","created_at":"2020-12-16T10:25:43.816Z","start_time":"2020-12-16T13:00:00","timezone":"Asia\/Jerusalem","duration":60,"topic":"Test Zoom meeting","type":2,"settings":{"join_before_host":false,"audio":"both","mute_upon_entry":false,"participant_video":false,"host_video":false,"use_pmi":true}}

However the user reports that this causes their PMI password to also change and that affects all their existing meetings. The existing meetings no longer work since the password changed.

Whaat are we doing wrong?

Here’s the response we get for the API call above by the way:

{"uuid":"******","id":*****,"host_id":"******","host_email":"******","topic":"Test Zoom meeting","type":2,"status":"waiting","start_time":"2020-12-16T11:00:00Z","duration":60,"timezone":"Asia/Jerusalem","created_at":"2020-12-16T10:25:45Z","start_url":"*******","join_url":"*******?pwd=dXRqR0xJNzcycENsd0FpOHljdGJLdz09","password":"fT!3pO*4qR","h323_password":"5144803585","pstn_password":"5144803585","encrypted_password":"dXRqR0xJNzcycENsd0FpOHljdGJLdz09","pmi":"******","settings":{"host_video":false,"participant_video":false,"cn_meeting":false,"in_meeting":false,"join_before_host":false,"mute_upon_entry":false,"watermark":false,"use_pmi":true,"approval_type":2,"audio":"both","auto_recording":"none","enforce_login":false,"enforce_login_domains":"","alternative_hosts":"","close_registration":false,"show_share_button":false,"allow_multiple_devices":false,"registrants_confirmation_email":true,"waiting_room":true,"request_permission_to_unmute_participants":false,"registrants_email_notification":true,"meeting_authentication":false,"encryption_type":"enhanced_encryption"}}

Hey @fahad.beehive,

Thanks for reaching out about this.

If you’re scheduling a meeting with use_pmi set to true, this would be expected behavior, though I realize this can be a bit confusing.

When creating a meeting using a user’s PMI, if a password is set in the API request body it will change the password of the user’s PMI as well.

In order to avoid overriding this value, you will need to turn off the use_pmi field/setting, which will generate a unique meeting ID separate from their PMI, and no longer override their PMI passcode.

Having said this, I realize this can be a bit misleading, and this is an experience we’re looking at improving in the future (ZOOM-163482).


Thanks Will. That’s certainly unexpected behavior, or slightly confusing as you say. What’s more confusing is that we’re following recommendations by using use_pmi based on the user’s account settings. If that’s truly what they want to do, and Zoom does not currently auto-assign a password in many cases (so we started supplying our own uniquely generated passwords), it can be annoying for the user to have their password replaced. Would be great if the two can be separated.

Also, being able to change their PMI password is scary - one could act maliciously, change their PMI password and then abuse the account.


Thanks for this feedback, @fahad.beehive, and I can definitely appreciate how this can seem misleading. I’ve followed up with our team on why this is currently the experience and have shared this feedback.

Thanks again for raising this with us,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.