Add a registrant webinar without last_name return 400 bad request

I’m trying to add a registrant using API. It works just fine until I set the last_name to null or to only space string. On the documentation page, the Add a webinar registrant API the last_name parameter is not required, only first_name and email are required. On the other hand, the Perform Batch Registrant API is working as expected when I set the last_name to null.

“code”: 300,
“message”: “The parameter is required: last_name.”

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Which Endpoint/s?
POST /webinars/{webinarId}/registrants

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Make a request API Add a webinar registrant. And set the value of the last_name parameter to null
  2. The API will return 400 bad request response codes. The response body message said, “The parameter is required: last_name.”
1 Like

Hi @mawan-fairtech

Thanks for reaching out to the Zoom Developer Forum!
You are right, on the docs page the Add webinar registrant API , the last_name parameter is not required.
I have tried to replicate the behavior you are seeing and I am not getting any error on my side.

I am passing only the email and first_name in the request body and I am getting a status 201 and getting a response body. I also tried passing last_name as null or as an empty string and again, I am not getting any errors.

Can you please confirm with me if you are still seeing this errors?

Hi @elisa.zoom, thanks for your response. I’m still able to reproduce the errors. Do you use this endpoint below?
POST /webinars/{webinarId}/registrants

Hi @mawan-fairtech

Thank you for sharing those screenshots with me. It is very strange cause I am using the same endpoint and I do not get any errors. I can pass the last_name as null or just don’t pass it and the registration is successful.

Could you please try creating a new webinar and try with a brand new WebinarID.

Thanks so much

Hi @elisa.zoom

Thanks for the response. Yeah, it’s very strange. I’ve tried to create a new webinar and the result is still the same. I might be using the batch registration endpoint to solve this issue at my end.

Hi @mawan-fairtech

Let me know if you can make it work with batch registration. If anything you can send an email to with the link of this thread and your accountId or email, so I can debug further.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.