Advanced meeting polls disabled. But is enabled, API polls dont work

Hi everyones, need helps with this problem.
I am trying to create a survey through the zoom api. These are the parameters that I am sending:
Endpoint
POST /meetings/83961927831/polls

{
"endpoint": "https://api.zoom.us/v2/meetings/83961927831/polls",
"response_headers": [
"Set-Cookie: zm_aid=""; Domain=.zoom.us; Expires=Thu, 01-Jan-1970 00:00:10 GMT; Path=/; Secure; HttpOnly"
],
"date_time": "2022-09-14 15:05:47",
"method": "POST",
"request_body": "{"anonymous":true,"poll_type":2,"questions":[{"answer_max_character":200,"answer_min_character":1,"answer_required":false,"answers":["Extremelyuseful","otrarespuesta"],"case_sensitive":false,"name":"Howusefulwasthismeeting?","prompts":[{"prompt_question":"Howareyou?","prompt_right_answers":["Good"]},{"prompt_question":"Howareyou3?","prompt_right_answers":["Bad"]}],"rating_max_label":"ExtremelyLikely","rating_max_value":4,"rating_min_label":"Notlikely","rating_min_value":0,"right_answers":["Good"],"show_as_dropdown":false,"type":"single"}],"title":"Learnsomethingnew"}",
"response": {
"code": 4400,
"message": "Advanced meeting polls disabled. To enable this feature, enable the 'Allow host to create advanced polls and quizzes' setting in the Zoom web portal's 'Settings' interface."
},
"request_headers": [
"accept: application/json",
"authorization: ******",
"connection: close",
"content-type: application/json"
],
"request_params": [
],
"http_status": "400"
}

all options are enabled in my settings

Any idea?

disclaimer
The test was performed while I had the meeting created.
I also scheduled a meeting and I keep getting the same error.

Hi @zoomaccounts2
Thanks for reaching out to the Zoom Developer Forum and welcome to our community!
I am happy to help here!
Allow me some time to do some testing on my end and I will come back with an update shortly!
Best,
Elisa

1 Like

Hi there @zoomaccounts2
I was not able to replicate your issue but I was able to look into my settings and played around with them and I think I can give you some advise.

Make sure to log in and go to your Settings, in the tab Personal > Settings
Once you are there you can go to Meeting > In Meeting (Basic) and you will find Meeting Poll/Quizes

Make sure to enable the Allow host to create advanced polls and quizzes feature like so:

This will do the trick :slight_smile:
let me know if this helps!
Elisa