Creating Meeting Poll via API issue

A Meeting Poll is created according to API documentation
{ :title=>“test poll”, :status=>“notstart”, :questions=>[{:name=>“test question 1”, :type=>“single”, :answers=>[“yes”, “no”, “maybe”]}], :zoom_meeting_id=>0123456789}

no error is generated when created through API, and the poll can be retrieved/edited via an API call with no error as well
However, once the poll is created the user ‘meeting details’ screen on the Zoom Website will no longer open and gives “Unable to display this page Zoom is temporarily unable to display this page.” Also, polling icon disappears from the meeting user interface, so the poll cannot be accessed

Delete the poll via the API, and the ‘meeting details’ screen is accessible, and the polling icon returns to the user interface.
If the poll is created via the Zoom meeting details screen…there is no issue…however if that poll is edited via the API…same issue as above then occurs…perhaps the API documentation is missing a required property? I do notice a ‘anonymous’ check box when Poll is created via meeting detail page, however the field/property does not present itself via the API…

Any help would be appreciated

thanks

Hey @Aaron_Lorenz,

This is strange. Can you please share a screenshot of the “Unable to display this page Zoom is temporarily unable to display this page.” page?

Thanks,
Tommy

Thanks @Aaron_Lorenz,

Can you also provide the meeting number where this was happening so I can look at the logs and reproduce the issue?

Thanks,
Tommy

meeting id = 117-675-751

1 Like

Thanks @Aaron_Lorenz,

What exactly are you passing in as the request body?

The status, and zoom_meeting_id fields are not listed on our docs.

Can you try this JSON request body:

{
  "title": "test poll",
  "questions": [
    {
      "name": "test question 1",
      "type": "single",
      "answers": [
        "Yes",
        "No",
        "Maybe"
      ]
    }
  ]
}

Let me know if that works.

Thanks,
Tommy