Android resource compilation failed error while upgrading to Meeting SDK android v5.10.6.6361

Hi, have you solve it ? Same problem exist on our project too.

“…/jars/classes.jar!/META-INF/rich-sdk_release.kotlin_module: Module was compiled with an incompatible version of Kotlin. The binary version of its metadata is 1.6.0, expected version is 1.1.16.”

I ran into this problem.

image

@umureg2

in some of your build.gradle files, they might be referring an older version of kotlin.
you want want to look for these instance, and change the version to 1.6.0 or higher

But the sample app for v 5.10.6 has different AGP.

Hi, I’m using same SDK version with the recommended AGP with compileSdkVersion 31. I ran into this error.
Multiple substitutions specified in non-positional format of string resource string/zm_text_mfa_sms_resend_176897. Did you mean to add the formatted="false" attribute?

My bad, your version is the correct default version.
I had accidentally used a different project in my screenshot

Are you still encountering additional error messages?

Yes I m stuck in the same place. Not able to resolve these errors. Can you help me with other versions less than 5.10.6?

Hi Janika ,
Did you get similar error like this

> Transform artifact mobilertc.aar (project :mobilertc) with DexingWithClasspathTransform
AGPBI: {"kind":"error","text":"Default method desugaring of `com.zipow.videobox.view.mm.r` failed because its super class `us.zoom.androidlib.app.ZMDialogFragment` is missing","sources":[{}],"tool":"D8"}
Default method desugaring of `com.zipow.videobox.view.mm.r` failed because its super class `us.zoom.androidlib.app.ZMDialogFragment` is missing


Not this exactly, but the Android resource compilation errors

I can’t really replicate your errors, but I had success using later version of gradle as shown on the screenshot

Can you share lower version of the SDK, cause this have too many dependencies to update.

2 Likes

The SDK access works on a self service model, downloadable via marketplace.zoom.us
The earliest version available now is v5.10.3.5593

Hi @janikagahalot ,
Did you also ran into Manifest merger failed with multiple errors, see logs?

Hello,

We are currently at 5.2.xxx and to update to 5.10.xx it requires major changes at our end as the dependencies introduced in the new versions are too many

dependencies.add("default","androidx.security:security-crypto:1.1.0-alpha03")

dependencies.add("default","com.google.crypto.tink:tink-android:1.5.0")

dependencies.add("default","com.google.android.exoplayer:exoplayer-core:2.16.1")

dependencies.add("default","com.google.android.exoplayer:exoplayer-ui:2.16.1")

dependencies.add("default","androidx.swiperefreshlayout:swiperefreshlayout:1.1.0")

dependencies.add("default","androidx.appcompat:appcompat:1.3.1")

dependencies.add("default","androidx.constraintlayout:constraintlayout:2.1.0")

dependencies.add("default","com.google.android.material:material:1.4.0")

dependencies.add("default","com.google.android:flexbox:2.0.1")

dependencies.add("default","androidx.multidex:multidex:2.0.0")

dependencies.add("default","com.google.code.gson:gson:2.8.1")

dependencies.add("default","com.github.bumptech.glide:annotations:4.11.0")

dependencies.add("default","com.github.bumptech.glide:glide:4.11.0")

dependencies.add("default","androidx.recyclerview:recyclerview:1.2.1")

dependencies.add("default","com.airbnb.android:lottie:4.0.0")

dependencies.add("default","androidx.window:window:1.0.0")

dependencies.add("default","androidx.window:window-java:1.0.0")

dependencies.add("default","org.jetbrains.kotlin:kotlin-stdlib:1.6.0")

dependencies.add("default","androidx.core:core-ktx:1.7.0")

dependencies.add("default","androidx.lifecycle:lifecycle-viewmodel-ktx:2.4.0")

dependencies.add("default","androidx.lifecycle:lifecycle-runtime-ktx:2.4.0")

Changing all the above dependencies and updating it is resulting in errors conflicting with our current versions.

We would want to get the minimum changes and dependencies required to integrate the version 5.10.xx so that we don’t face too many errors.

For example we tried to comment out dependencies.add("default","androidx.constraintlayout:constraintlayout:2.1.0") and the sample project was building fine.

Please mention all the minimum dependencies required with their minimum versions.

Also please mention the minimum Gradle version and Android Gradle Plugin version required to integrate it.

@chunsiong.tan Any help here?

@janikagahalot Hi, I just found a way to debug this issue .

  • 1st bring all the dependencies from your project to zoom sample application and check whether the same issue exist.

  • 2nd comment your dependencies one by one and build the zoom sample application this will lead to finding the dependency that has conflict with zoom sdk .

I’m currently trying this method and It looks promising . Hope this help.
Also if you found any idea or the dependency please share it and I will do the same .

@janikagahalot Do you have this package name com.droidninja:filepicker:2.2.1 ?
Mine was conflict between this package and zoom sdk

1 Like

@geet Thank you!

Yes we also tried in the same way, figured out material library was making issue.

2 Likes

Is it solved? I also facing that type of issue although i try some trick to overcome that issue but when start again happen this.