Android resource compilation failed error while upgrading to Meeting SDK android v5.10.6.6361

Hello,

I have followed the step to upgrade the Meeting SDK android, but still receiving error

AAPT: error: duplicate value for resource ‘attr/overlay’ with config ‘’.
aand more

Android resource compilation failed.

Currently I m on

Android studio: bumblebee
Gradle version: 6.7.1
min_sdk_version = 21
compile_sdk_version = 30
target_sdk_version = 30

buildToolsVersion: 30.0.2

trying to upgrade to v5.10.6.6361

Hi,
I have been search how to upgrade zoom SDK and I find this, can you share the instruction link ?

Thank you

I followed the documentation Prerequisites

Thanks, by the way , do you have any idea to check current version of Zoom SDK other than version.txt file?

No worries I have found it Class Zoom SDK

Please help here, this is pressing issue for us as we have to upgrade the Zoom SDK in android cause the one we have will deprecate in 4 days.

@janikagahalot,

Here are some high level steps.

  1. download the sdk from marketplace.zoom.us, specifically 5.10.6.6361 for your case
  2. copy the commonlib.aar and mobilertc.aar from the SDK, and paste them into the relevant directory in your project
  3. check if have any missing dependencies on your build.gradle file. below is the build.gradle for 5.10.6.6361
configurations.create("default")
artifacts.add("default", file('mobilertc.aar'))

dependencies.add("default","androidx.security:security-crypto:1.1.0-alpha03")
dependencies.add("default","com.google.crypto.tink:tink-android:1.5.0")
dependencies.add("default","com.google.android.exoplayer:exoplayer-core:2.16.1")
dependencies.add("default","com.google.android.exoplayer:exoplayer-ui:2.16.1")
dependencies.add("default","androidx.swiperefreshlayout:swiperefreshlayout:1.1.0")

dependencies.add("default","androidx.appcompat:appcompat:1.3.1")
dependencies.add("default","androidx.constraintlayout:constraintlayout:2.1.0")
dependencies.add("default","com.google.android.material:material:1.4.0")
dependencies.add("default","com.google.android:flexbox:2.0.1")
dependencies.add("default","androidx.multidex:multidex:2.0.0")
dependencies.add("default","com.google.code.gson:gson:2.8.1")
dependencies.add("default","com.github.bumptech.glide:annotations:4.11.0")
dependencies.add("default","com.github.bumptech.glide:glide:4.11.0")

dependencies.add("default","androidx.recyclerview:recyclerview:1.2.1")
dependencies.add("default","com.airbnb.android:lottie:4.0.0")

dependencies.add("default","androidx.window:window:1.0.0")

dependencies.add("default","androidx.window:window-java:1.0.0")

dependencies.add("default","org.jetbrains.kotlin:kotlin-stdlib:1.6.0")
dependencies.add("default","androidx.core:core-ktx:1.7.0")
dependencies.add("default","androidx.lifecycle:lifecycle-viewmodel-ktx:2.4.0")
dependencies.add("default","androidx.lifecycle:lifecycle-runtime-ktx:2.4.0")

dependencies.add("default","androidx.fragment:fragment-ktx:1.4.1")

I have added these dependencies in the build.gradle of mobilertc. And tried sycning it, it was giving the same errors.
I have also tried adding these dependencies in the build.gradle of app also, and still facing these issue.

Can you help me where exactly to add these dependencies?

1 Like

These were already part of our app’s dependencies as we were using sdk earlier as well.

  1. As mentioned by @chunsiong.tan I have copied and pasted the aar files from the SDK project to our project.
  2. Updated dependencies in the build.gradle of the mobilertc
  3. Cleaned build
  4. Invalidate cache and restarted
  5. Build the project
  6. Facing the below errors.
    I am adding the screeshots of the error messages.


Hi @janikagahalot,

Is the build folder within commonlib and mobilertc empty in the first place before your initial build with the new SDK?

Do ensure you have a copy of your original codebase, before attempting any deleting / emptying of folders

No the build folder within commonlib and mobilertc was not empty

@chunsiong.tan Can you provide the source code for version 5.4.3.603. So that we dont face so many dependencies issue and we need this upgrade before 6th August.

1 Like

could you try clearing the build folders? do ensure you have a backup of your source code.

meanwhile, any reasons why you are not using the latest build on 5.11?

Cause we are using very old version of zoom, and to upgrade it directly to the latest version will require update in dependencies also which we don’t have time for as Zoom is deprecating the SDK version below 5.4.0 on 6th. I m trying to upgrade it to 5.10.6 but still facing so many dependencies issue.

I feel it would be easier if I tried with 5.4.3.603.

1 Like

Tried building by deleting the build folders of commonlib and mobilertc, still facing the same issue.

some other hygiene checklist

check for presence of build.gradle scripts in your project

check for present / conflicting dependencies in your project structure

I have checked it has all the things. Would really appreciate if you can guide me step by step and redirect me to the source code for bare minimum version upgrade required 5.4.3.603. As it would be easier for us.

@chunsiong.tan
What I understand is these errors are because of dependencies and for us to upgrade the dependencies also will be a major change right now. Anyway we can get the source code for 5.4.3?

Or any other way you can help me resolve these errors ?

@chunsiong.tan Can you help me with the Android Gradle plugin version required for integration?