App Compiling Error - Android resource linking failed

Hello dear developers.

Today I have signed up for ZOOM SDK to develop a mobile app and downloaded SDK by official documentation.

I have downloaded most latest mobile aar and commonlib aar files and Added them as a dependency in the module-level build.gradle file.

This setup is successful. So now, I decided to compile the app. When I start to compile this app in the latest Android Studio, I get the following error:

Android resource linking failed
E:\My Projects and Source Code\Current Work\Cricket Live\mobilertc\build\.transforms\76efb555d3ccaf1872292af68f9b4685\jetified-mobilertc\res\values\values.xml:71:5-95: AAPT: error: resource color/zm_v1_orange_50_alpha14 (aka com.methewlive.app:color/zm_v1_orange_50_alpha14) not found.
    
E:\My Projects and Source Code\Current Work\Cricket Live\mobilertc\build\.transforms\76efb555d3ccaf1872292af68f9b4685\jetified-mobilertc\res\values-night-v8\values-night-v8.xml:3:5-95: AAPT: error: resource color/zm_v1_orange_50_alpha29 (aka com.methewlive.app:color/zm_v1_orange_50_alpha29) not found.
    
E:\My Projects and Source Code\Current Work\Cricket Live\mobilertc\build\.transforms\76efb555d3ccaf1872292af68f9b4685\jetified-mobilertc\res\values-night-v8\values-night-v8.xml:28:5-94: AAPT: error: resource color/zm_v1_white_alpha40 (aka com.methewlive.app:color/zm_v1_white_alpha40) not found.
    
E:\My Projects and Source Code\Current Work\Cricket Live\mobilertc\build\.transforms\76efb555d3ccaf1872292af68f9b4685\jetified-mobilertc\res\values\values.xml:5121:5-5125:10: AAPT: error: resource color/zm_v2_label_account_status (aka com.methewlive.app:color/zm_v2_label_account_status) not found.
    
E:\My Projects and Source Code\Current Work\Cricket Live\mobilertc\build\.transforms\76efb555d3ccaf1872292af68f9b4685\jetified-mobilertc\res\values\values.xml:5126:5-5128:10: AAPT: error: resource color/zm_v2_label_title_account_status (aka com.methewlive.app:color/zm_v2_label_title_account_status) not found.
    
E:\My Projects and Source Code\Current Work\Cricket Live\mobilertc\build\.transforms\76efb555d3ccaf1872292af68f9b4685\jetified-mobilertc\res\values\values.xml:5221:5-5224:10: AAPT: error: resource dimen/zm_btn_largest_height (aka com.methewlive.app:dimen/zm_btn_largest_height) not found.

From my understanding, I believe that is because of missing resource values in mobilertc.aar file.

I found it very weird. Please help me fix this issue. Thank you.

Hi @ultechnologies2006, thanks for using our SDK.

Please take a look at the build.gradle file in the mobilertc module of the sample app and ensure that the same file in your project is configured in the same way. :slightly_smiling_face:

Thanks!

Like, what do you mean?

I have the following modules:

mobilertc
commonlib
app

In settings.gradle I have added folowing:

include ':mobilertc'
include ':commonlib'

in app module build.gradle file I have following:


implementation project(':mobilertc')
implementation project(':commonlib')

I have also tried

sample

module from ZOOM SDK folder and found that the problem is still the same.

I feel very sorry for this. I use Gradle 6.1.1, Android SDK 30, MIN SDK 21, Target SDK 30

Hi @ultechnologies2006,

If you take a look at the sample app, this is what you will find in the mobilertc/build.gradle file:

configurations.create("default")
artifacts.add("default", file('mobilertc.aar'))

dependencies.add("default","androidx.security:security-crypto:1.1.0-alpha02")
dependencies.add("default","com.google.crypto.tink:tink-android:1.5.0")
dependencies.add("default","androidx.swiperefreshlayout:swiperefreshlayout:1.0.0")

dependencies.add("default","androidx.appcompat:appcompat:1.0.0")
dependencies.add("default","androidx.constraintlayout:constraintlayout:1.1.3")
dependencies.add("default","com.google.android.material:material:1.2.0-alpha03")
dependencies.add("default","com.google.android:flexbox:2.0.1")
dependencies.add("default","androidx.multidex:multidex:2.0.0")

Doing the same in your project should resolve the issue you are seeing.

Thanks!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.