AndroidTV zoom demo app - no sound (mic)

I’m using the Basic Demo app on my androidTV box. I have the USB camera with the microphone connected. The video quality is pretty good, however, the meeting participants can’t hear me. Although my mic icon is unmuted. When connecting to debug I see only one error:
dead IAudioRecord, creating a new one from obtainBuffer().

The other similar apps, like DUO or Microsoft Teams works correctly.

Will appreciate any help.

Hi @oleg.roberman, thanks for using the devforum.

We’ve seen a similar issue reported recently with the SDK. This may be due to the lack of support for USB audio devices. We can confirm that this is the issue you are encountering by testing on the same device using a bluetooth audio device if your TV supports bluetooth audio. Let me know if you have any questions or have been able to test with a bluetooth device.

Thanks!

Hi We have faced the same issue, and we did plug usb webcam (with mic ) on Android TV.
Other conference solution like Vidyo can get the mic with the provided SDK.

Is it caused by not supporting USB UVC?

Thanks

Hi @Chi-gun_Huang,

We can confirm whether or not it is an issue with support of your device if you are able to test with a bluetooth device and successfully get audio working. I’ve seen instances of this problem where the issue is being caused by improperly implemented audio drivers as well, but it is difficult to say for sure without testing whether or not bluetooth audio works.

Thanks!

Hi @jon.lieblich
We have found that when we set
MeetingSettingsHelper msHelper = zoomSDK.getMeetingSettingsHelper();
msHelper.setAutoConnectVoIPWhenJoinMeeting(true)

when zoom sdk initialized success.

It fail to open the mic when first join to the meeting, but always success to open the mic the next time join to the meeting.

We will trying to test whether the bluetooth can be launched when meeting.

Thanks

Hi @Chi-gun_Huang, thanks for the additional info.

Just to clarify, when you say that you are able to successfully open the mic the second time, does that mean that this is working correctly? Or are you just saying that the callback is indicating that it was successful and you are still unable to use your mic in a meeting?

Thanks!

Hi @jon.lieblich
I’m sure that the device supports USB audio devices because google DUO is working well.

I realized that the mic working correctly with zoom SDK on Android 10 devices, however on android 9 it’s not.

Hi @oleg.roberman, thanks for clarifying.

I definitely do not suspect that the device is what is causing the issues here, but rather the system-level audio APIs used internally by the SDK.

That is very interesting that this issue is only present on Android 9. Is this the same device model running different Android versions that you are using to test, or are they two different devices which are also running different versions?

Thanks!

Hi @jon.lieblich
Those are actually 2 different devices from the same manufacturer.

Hi Thanks for your response, Is the issue will plane to fix on Android 9? Thanks

Hi @Chi-gun_Huang,

Without specific details on the device models, we cannot confirm whether this is an issue with the Android version or the device model.

Thanks!

Hi thanks for your response. Should i provide the device model name only or sending the demo device to you? Thanks

Hi @Chi-gun_Huang,

Please provide as much information about the device make/model as you are able. :slightly_smiling_face:

Thanks!

Hi
I have the same problem with a Logitech C920 and a Mi Box S. Video OK, sound KO.
It work fine with Google Duo.
If you have a solution…
Thanks !

Hi. I’m sorry to get into this matter.
I’m new on android tv. So any sily mistakes please forgive me.
I have a sony bravia h80x running Android tv 9
I have the same issue with zoom.
I have tried using bluetooth and still no getting any input from microphone.
I have use zoom on android box tv 10. Any it works perfectly.
Any idea how to solve this matter.
Thanks guys
Blessings!

Update

I don’t have microphone input on any video call app. ,:sob: In that case I’m sure I have to look for help somewhere else.
Any way. Any help will be appreciated.

Hi
Can you tell me me which android tv box run on Android 10 ?
Thanks

Hey @bpontieux & @jlatacela1 ,

Thanks for using the dev forum!

Are you using the Zoom Android SDK? This forum is only for Zoom SDK developer questions.

Thanks!
Michael

Hi Michael. No I’m using the regular app.
I’m just a final user.
I’m sorry if I’m on the wrong forum.
Thanks.

transpeed Android 10.0

Hey @jlatacela1,

No need to apologize :slight_smile: This happens all the time. You should be able to get help over at https://support.zoom.us/hc/

Thanks!
Michael