Attempting to list meetings always returns an empty meeting list

If I try to use the (GET /users/{userId}/meetings) endpoint to list the meetings for a user, I always get an empty list of meetings.

In particular meetings created by the macOS native client do not show up. And meetings created by the (POST /users/{userId}/meetings) endpoint also do not show up.

API response: {“page_count”:0,“page_number”:1,“page_size”:30,“total_records”:0,“meetings”:}

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Which Endpoint/s?
GET /users/{userId}/meetings

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Create meeting with macOS native client. Or with (POST /users/{userId}/meetings) endpoint.
  2. Call (GET /users/{userId}/meetings) endpoint on the same user.

Always receive response: {“page_count”:0,“page_number”:1,“page_size”:30,“total_records”:0,“meetings”:}

Additional context
I am trying to list meetings to support the following logic:

If you use the Web SDK to start a meeting and join it as a host when that user already has other hosted meetings running, the SDK will fail with an error message when joining. I need to workaround by detecting this error message, listing & ending all other meetings that the user is hosting, and then retrying the join.

1 Like

Seeing the same thing. Seems like Zoom’s API is broken.

Hey @david.foster, @erahhal,

Are you passing in the correct query param? By default the Get User Meetings endpoint queries live meetings.


I have tried all of the query params. In particular I have tried the “scheduled” query param which should list ALL meetings I believe, and also got zero results. (FWIW, the user account I used is relatively new so it would have only had 11-digit meetings in its history, and I suspect this endpoint may be specifically failing to list 11-digit meetings.)

Even if I was only querying live meetings, I did had live meetings at the time I queried the endpoint which should have showed up but did not.

Hi Tommy,

I also tried all the three “type” options to no luck. What I found out is that I only see meetings that were created as “type: 2”, which is a “scheduled” meeting. If I create a meeting of “type: 1” (Instant meeting), it does not show up in the list of meetings. Is this intentional? If so, how do we get the list of instant meetings? Do they eventually expire?

Hey @erahhal,

Yes it is intentional, instant meetings will not return from the get meeting endpoint unless they are live.

@david.foster, are you also using an instant meeting?


Hi @tommy, yes I am using an instant meeting. The repro step above that reads “Create meeting with macOS native client.” specifically means press the big “New Meeting” button which creates an instant meeting.

@tommy do you need any additional information to attempt a repro?

Hey @david.foster,

If only the host is in the meeting, it will not be returned from the List Live Meetings endpoint since it is not considered a “meeting” with just one host/participant.