Being admitted in from waiting room enables audio

How do I prevent the audio from being enabled (or disable it again programmatically ) when I join a Zoom meeting via the Waiting Room?

Which version?
zoom-sdk-android-master v4.6.21666.0429

Smartphone (please complete the following information):

  • Device: Samsung S9
  • OS: Android
  • Version : latest

I start the meeting with
opts.no_audio = true;
opts.no_video = true;

When there is no wanting room, I join without audio.
When there is a waiting room, I join with audio on (and video too)

I want to join without audio and video in all cases.

Thank you for your help

1 Like

Hi @frank, thanks for the post.

In order to mute all members when they join the meeting, you can use InMeetingAudioController#setMuteOnEntry. You may retrieve an instance of this controller by calling ZoomSDK.getInstance().getInMeetingService().getInMeetingAudioController();. Hope this helps!


Thank you for your prompt reply.
I am not the host in the meeting.
I simply want to join the meeting without my audio connected.
I use the parameter no_audio=true when joining the meeting.
My audio is not connected when there is no waiting room and I join the meeting. But when there is a waiting room, my audio is connected when I am allowed in the meeting.
Is there a way to perform the UI command “Leave Audio” with the Android SDK?
Thank you
Thank you

@frank, my apologies for the misunderstanding and thank you for clarifying.

If you would like to disconnect your self audio as an attendee, you just need to call InMeetingAudioController#disconnectAudio. You can obtain a reference to the controller via ZoomSDK.getInstance().getInMeetingService().getInMeetingAudioController();.


Thank you
I added disconnectAudio() to the meeting status change callback when meetingStatus == …INMEETING
It works