Bot Slash Commando Not working Properly

#1

When trying to invoke the bot through its slash command i get no return on my Endpoint, just a http request with no json payload as stated on the documentation.

Slash command has been set, urls (Both different from eachother) have been set, proper scopes have been selected and publishable url has been refreshed.

I get the same type or request as if some one texted the bot without the command slash.

0 Likes

#2

Hi,

Can you please provide some screenshots showing the issue?

0 Likes

#3

image

This shows the slash command, I invoke it through “/api” on the group. Also whenever i type anything on a 1 on 1 with the bot, i get the same answer:

0 Likes

#4

image

This is the response a get, it has no payload, just a simple http request.

0 Likes

#5

This are my scopes:
image

0 Likes

#6

Hi,

Can you please share the output as well which you are receiving ?

0 Likes

#7

As stated before,the only output i recieve is a http request with no payload, image

0 Likes

#8

Hi Jorge,

Apologies for the inconvenience caused.

Please let me know if you are following these steps:

  1. You are using the correct credentials and the correct environments, i.e: “Dev” or “Prod”
  2. Steps mentioned here

if you are following the steps correctly, and still facing the issue, can you send me the code that you are using to send the message?

Alternatively, we have just published a tutorial here and you can also find the code here

Let me know if you have any questions.

0 Likes

#9

Answering your questions,

  1. Im using the correct credentials as the bot do send messages. And recieve petitions when resquested, they just come in blank

  2. I did followed that documentation.

  3. Im using the next code, which @Michael_Purnell sent to us. https://github.com/zoom/zoom-bot-api/blob/master/sendBotMessage.js

Ill try your tutorial to see if i can replicate it and find my error.

0 Likes

#10

@Ojus Im using your code as i want to get this “commands” methodology to work on my code, but i dont seem to make it work. I set up the credentials correctly on the config file and redirected my localhost to port 3003 using serve (Substitue for ngrok) but it dowent seem to work correctly. whenever i type on the client y get the petitions but still no payload or response from the bot. I tried with the slash command, without the slash command, 1 on 1 chat, still blank petitions. Also whenever i tried to make the get request with /message i get in the console log "payload format error.

Is there a way in which we can engage through a zoom meeting? I think this will get solved in minutes with you live help.

Thanks.

0 Likes

#11

Hi Jorge,

Please make sure that you have configured the URL’s correctly.
If you are using the above code, make sure your URL’s are in the following format:

In App Marketplace, App credentials

Redirect URL for OAuth : https://YourURL/oauth

See this example:

In App Marketplace, Chat subscription

Bot Endpoint URL: https://YourURL/message

See this example:

In config,js
Redirect URI / URL = https://YourURL/oauth

Let me know if that resolves your issue

0 Likes

#12

i have changed the urls as stated, but it still wont work. Now i get a verification error despite i have the correct info on the config files. I have tried for both development and production config info.

Also i have tried using the setting.setUrl(‘https://dev.zoom.us’);.

As i am from flex, i have also tried changing ‘https://dev.zoom.us’ for both of the flex tenants, de production and test ones.

In all this 4 cases I have tried with both config clients, production and development.

image
image
image


0 Likes

#13

Sorry forgot to add the outputs,

image
image

0 Likes