Callerid parameter in zoom phone URI scheme does not work in android devices

zoomphonecall:XXXX?callerid=XXX

We are facing a few issues integrating zoom with Android devices.

Use Case: Outgoing calls using zoomphonecall URI scheme from desktop and mobile devices.
We have a button on our web portal, user clicks on it to initiate zoom call. Our web portal is responsive and accessible from desktop and mobile devices. The current URI we are using:

  • zoomphonecall:+XXX?callerid=+YYY

The callerid parameter is important for our business requirements. For desktop it’s working fine, but on Android the same URI scheme returns “Invalid phone number” error. But when we remove callerid parameter from the URI it works fine on android as well.

  • zoomphonecall:+XXX?callerid=+YYY>> Works form web/desktop but not for android
  • zoomphonecall:+XXX>> Works for android

Required/expected results:
callerid parameter in the URI works for android devices just like they do on desktop. Is there a way to replicate the callerid web/desktop behavior on android? Is the callerid parameter supported on android at all? if not, is there any workaround for it?

Please let me know if you have any questions in this regard. Thank you.

Regards,
Aaqib

Hi @aaqib.iqbal ,

Let me look into this further and get back to you!

Best,
Gianni

Thank you, looking forward to hearing from you soon.

Hi @aaqib.iqbal ,

I think this may be a bug as we have another customer reporting this whereas our tech and service engineering team says this is unexpected behavior.

Can you please open up a support ticket with this issue? Share your account id, this thread and screenshots of the behavior.

Thanks!

I already did and this is their response:

My Engineering team just consulted the Zoom Phone team who confirmed that it is not possible to use a custom number to make outgoing calls from Android since it is not supported due to system security concerns. Any call that was initiated from an android device likely originated from a different number.

Is there any workaround for this? This is our core business logic where we want to send outbound calls through custom numbers instead of the user’s personal zoom number. Most of our users are on android platform, i’m afraid we won’t be able to proceed with Zoom if this feature is not supported.

Thank you.

Hi @aaqib.iqbal ,

Can you please share the ticket number with me so I can look into this internally?

Please find below:

https://support.zoom.us/hc/en-us/requests/15215258?page=1