Cannot make ScheduleMeetingsListView item clickable

I am using the SDK “sample” app in order to learn the SDK, and make an alteration to the PreMeetingExampleActivity to make the SchelduleMeetingListView items clickable to launch a meeting.

Which version?
SDK: 2020-06-30 @ v5.0.24433.0616
Android Studio: 4.0

To Reproduce(If applicable)
In the onCreate() Override in, I have added the following code below mListView.setAdapter(mAdapter);

  mListView.setOnItemClickListener(new ScheduledMeetingsListView.OnItemClickListener() {
  									 public void onItemClick(AdapterView<?> parent, View view, int position, long id) {
  										 Log.i(TAG, "Meeting Item clicked.");

When the PreMeetingExampleActivity is displayed, and I touch any scheduled meetings, this is not called.
I have tried “new ListView.OnItemClickListener”, “new AdapterView.OnItemClickListener()” and anything else I can think of, all with the same result. Clicking on any scheduled meeting item displayed in the PreMeetingExampleActivity is the same, the onItemClick Override is never called.
Any assistance/advice on what I am doing wrong appreciated.

Smartphone (please complete the following information):

  • Device: Google Pixel 2
  • OS: Android
  • Version 10

Additional context
The reason I am altering the sample app from the SDK is that any time I try and create a Project and add the SDK to it, even if I copy code from the SDK, it refuses to initialise the SDK.

It is urgent I create this locked down meeting app in the next few days, and I am getting nowhere fast.

Hi @john.a.stevens,

Thanks for the post. The SDK itself does not have any restriction to the list view item itself so you could implement the onclick event. As the issue you are facing is not related to SDK interface so we might not be the best person to speak with. The code snippet provided looks good so the issue might caused by something else. The following links could be helpful:


Thanks Carson,
Tried all of those and nothing worked. So instead I am putting “Join” buttons on all the items and processing onClick functions on the buttons. Working fine, just would have been nice not to need the buttons.
If I ever get to properly integrate the SDK into a blank Project and start from scratch, I might figure it out then.
Every time I try to add the SDK into a blank project, it builds, but it does not ever properly initialise the SDK. Even if I copy the code from the “sample” app into it.
There must be something I am missing. Set all the dependencies correctly (it builds).