Can't join Audio by Computer on android devices (WebSDK)

I’m having a weird trouble with the websdk on android/chrome. for webinars, the “Join Audio” button is disabled.

It works fine on chrome desktop, and seems to work on chrome/android, same simulator/phone when switching chrome to “Desktop website”

Browser Console Error
The full error message or issue you are running into.

Which Web Meeting SDK version?

  • 2.9.5

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Go to ‘…’
  2. Click on ‘…’
  3. Scroll down to ‘…’
  4. See error

If applicable, add screenshots to help explain your problem.

Troubleshooting Routes

  • Tried same website (locally and live website), on desktop browsers including chrome/safari, joining the meeting seems to work fine.
  • The client complained it doesn’t work on chrome/android phones (Join Audio by Computer) button is disabled.
  • Tried on chrome on android emulator, button is disabled.
  • Switched chrome in emulator to use desktop website, (not very user friendly, but button was enabled, and I could join audio)
  • From the chrome desktop version, tried chrome developer tools, mobile view, tried with "Samsung galaxy S8+), button was disabled
  • Switched to (iPhone SE) , button is enabled.

This seems quite like the zoom websdk for some reason doesn’t allow joining by audio when useragent is related to android.

Any ideas about how to fix it?

Device (please complete the following information):

  • Device: [e.g. Macbook Pro]
  • OS: [e.g. macOS 11]
  • Browser: [e.g. Chrome]
  • Browser Version [e.g. 88.0.4324.150 (Official Build) (x86_64)]

Additional context
Add any other context about the problem here.

Thanks for the detailed description @mbkfa93! Are you seeing any errors in the JavaScript console?

@MaxM Thanks for checking the issue,
This is a duplicate of Can't join Computer audio from chrome on Android devices - #9 by donte.zoom

and regarding the js errors, I’ve compared between the logs of a working version (non-android user agent) and another one with the issue, there seemed to be a few more logs in the working one (not of error type)

but it seems from the other post that the engineering team is already aware of the issue, and I’m waiting for the new release with the fix.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.