Can't join Computer audio from chrome on Android devices

I’m having a weird trouble with the websdk on android/chrome. for webinars, the “Join Audio” button is disabled.

It works fine on chrome desktop, and seems to work on chrome/android, same simulator/phone when switching chrome to “Desktop website”

Which Web Meeting SDK version?

To Reproduce(If applicable)

  • You can try on this link (currently no validation on email or username)

Troubleshooting Routes

  • Tried same website (locally and live website), on desktop browsers including chrome/safari, joining the meeting seems to work fine.
  • The client complained it doesn’t work on chrome/android phones (Join Audio by Computer) button is disabled.
  • Tried on chrome on android emulator, button is disabled.
  • Switched chrome in emulator to use desktop website, (not very user friendly, but button was enabled, and I could join audio)
  • From the chrome desktop version, tried chrome developer tools, mobile view, tried with "Samsung galaxy S8+), button was disabled
  • Switched to (iPhone SE) , button is enabled.

This seems quite like the zoom websdk for some reason doesn’t allow joining by audio when useragent is related to android.

Any ideas about how to fix it?

Device :

  • Device: Any android device, even Chrome Desktop version with any Android device useragent
  • OS: Android
  • Browser: Chrome
  • Browser Version 108.0.5359.128

Thanks in advance

@mbkfa93 ,

Thank you for the details description of the behavior you are seeing. I tested via the link but it looks like the webinars may be outdated. To confirm, are you saying you are able unable to join audio from the browser when using an android device? If so, can you share what version of the android device you tested with?

perhaps a similar webinar mobile issue [ZOOM-460799]

@donte.zoom Thanks a lot for your fast reply. The webinar was open for a while for testing, and it was left open for a while for testing, but it seems like it’s closed now.
if you’re available to give it a quick look, give me a time and I’ll try to schedule it with one of the organizers

The issue is that the “Join Audio by Computer” button is disabled, and I’ve mentioned the cases above and I believe it’s related to user agent, because on the same device, it works on chrome “Desktop Site” , tried that on

  • Android Emulator running Android 13, with Chrome 103.0.5060.71
  • Mi 9 Lite running android Android 11 with Chrome 108.0.5359.128

Same for client’s phone (but I don’t know much details about it)

What almost confirmed it to me is the Chrome desktop developer tools method. seems to not work on different android user agents, and seemed to work fine on ios user agents …

Let me know if there are any further details I can share that can help

I haven’t really tested on older versions of the sdk, and I’m not getting the same error mentioned in the first post. Also my issue is in chrome/android, seems to be working fine in iOS

and I believe I’ve checked that thread before posting, and it seemed like a different issue

Hey @donte.zoom are any more details needed from my side to help get this fixed soon?

Thanks in advance

@mbkfa93 ,

I wanted to provide a follow-up on this issue. Our engineering team is aware of the issue and the fix will be included in the Meeting SDK 2.9.7 release, which is expected to be released at the end of December or within the first couple weeks of January. To stay informed about this and other updates, you can visit the following link:

1 Like

Many thanks @donte.zoom , Looking forward to that update.

Have a lovely day :slight_smile:

1 Like


You’re very welcome and I hope you have a wonderful and relaxing day a head.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.