Web SDK - Your browser doesn't support

I’ve seen lots of topics about this. But I’ve not found actual solutions.

Your browser doesn’t support using computer’s Audio device, please upgrade your browser to the latest version.

Meeting sdk - web
version: 2.17.0

Chrome (Version 118.0.5993.118)
Latest version as of making this topic

Https: yes
OS: windows

I can’t share my video

If I also join via the app and share my video.
On the websdk I see the user join. But I don’t see their screen.

What am I missing?

Thank you for posting in the Zoom Developer Forum. It seems that your browser needs to be updated in order to use the audio. Could you please update your browser and let us know if the issue persists?

I already posted the chrome version and that it was the latest version.

I’ve actually realised that the issue relates me having isSupportAV:false in the config.
I misunderstood what it is for.

Are there any guides to managing participants vs attendees?

I don’t want attendees to go through the audio \ visual setup as they aren’t presenting. But it seems that turning off isSupportAV shuts down everything to do with video\audio.
You can’t send OR receive video.

I think I’m misunderstanding the role flag.
Doesn’t role:0 mean attendee?

It doesn’t seem to change anything. If I join with role:0
I still get asked to setup my video\audio
I still can share my video to the meeting

How do I actually make someone join as an attendee?

ok, it looks like I’m thinking about “webinars”.
Meetings doesn’t support attendees.

I’ll try doing webinars instead.

Okay, I see. That message probably could be better, but glad you figured out the issue was having isSupportAV:false in the config.

Yes, correct.

host = 1
participant/attendee = 0

Can you clarify what you mean by managing participants vs attendees? Do you mean managing host and co-host vs participants?

I believe that is the expected behavior. Are you interested in not sharing video and audio as well? Or are you specifically trying to prevent participants/attendees from sharing their screen? If the latter is the case, you can disable screenshare using the init, or you can hide the button using CSS.

You can join by participant/attendee by assigning the role: 0

@Meathead ,

Also, here is the Web SDK Webinar support documentation :


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.