Can't retrieve data when Meeting UUID contains double slash ("//")

hi @pavol,

Glad that your issue has been resolved. Please let us know if you have any questions.

Thanks

Hey @zhangi,

How are you encoding the url? I come up with different results via https://www.urlencoder.org/

no escape(MOBErow9Q7yma0L/LmeqRg==)
single encoding(MOBErow9Q7yma0L%2FLmeqRg%3D%3D)
double encoding(MOBErow9Q7yma0L%252FLmeqRg%253D%253D)

Can you try using: MOBErow9Q7yma0L%252FLmeqRg%253D%253D

Thanks,
Tommy

1 Like

The issue I experienced is not related to the encoding, sorry.

1 Like

No worries @zhangi!

Please let us know if you have additional questions. :slight_smile:

Thanks,
Tommy

I’m having a similar issue. I would expect that the encoding used by the API when I:

GET: https://api.zoom.us/v2/past_webinars/247065729/instances

{
  "webinars": [
    {
      "uuid": "dTXi1//NSBKh0IVZfTekMg==",
      "start_time": "2020-03-13T15:46:26Z"
    }
  ]
}

matches the one accepted in a subsequent query:
GET: https://api.zoom.us/v2/report/webinars/dTXi1//NSBKh0IVZfTekMg==/participants

{
    "code": 3001,
    "message": "Meeting ID is invalid or not end."
}

which doesn’t.

Note that, single encoding didn’t work. But double, did.

Hey @alejandrodini,

Yes, right now you must double encode if there are slashes in the uuid. We are working to fix this in a future release. Stay updated here: https://marketplace.zoom.us/docs/changelog

Thanks,
Tommy

I am trying to get information from the API using Postman
I have a meeting ID with a single slash and I get 3001 This meeting is not available or ID is not valid.
I got the Meeting ID from a previous API call the /users/{xxxyyyzzz}/meetings
I have tried calling /past_meetings/{meeting UUID}
I have tried plain meeting UUID blah/moreblah==
I have tried single and double URL encode of blah/moreblah== and I keep getting the same 3001 error
Can anybody suggest anything please as I am stumped at this point. I need to get a participant list from this meeting ASAP.
Regards

Angus

Hey @angus.denton,

What meeting id and uuid are you trying to use?

Thanks,
Tommy

Hi
@Tommy Gaessler via Zoom Developer Forum

I have discovered that the ‘Dashboard’ API /metrics/reports a different UUID for a past meeting than the getting the meeting uuid returned from the /users/{userid}/meetings call,

Why a meeting event changes UUID is a mystery and I spent too long chasing this one around. The /metrics/ api returned an actionable UUID.

Gus

1 Like

Hey @angus.denton,

Correct. After the meeting is started, it transitions to a new meetingUUID.

Thanks,
Tommy

i’m sharing my solution here, at least for my code

def double_quote(str_in):
if str_in[0]=="/":
str_in="%252F"+str_in[1:].replace("/","%252F").replace("=","%253D").replace("+","%252B")
if “//” in str_in:
str_in=str_in.replace("/","%252F").replace("=","%253D").replace("+","%252B")

return(str_in)
1 Like

Thanks @zye! :slight_smile:

-Tommy

Hello Team,
I am using a paid account and have admin access.

meetingUUID is correct which I have retrieved from /meetings/{meetingId} API.
Meeting Id = ‘97676863012’
Meeting UUID = ‘FEtRDSUbQ3GKs8y0G3yLJg==’

I am facing the same issue while hitting URL “/past_meetings/{meetingUUID}/participants”

before encode meetingUUID: FEtRDSUbQ3GKs8y0G3yLJg==

after encode meetingUUID: FEtRDSUbQ3GKs8y0G3yLJg%253D%253D

endPoint: https://api.zoom.us/v2/past_meetings/{meetingUUID}/participants

res.getBody(): {“code”:3001,“message”:“Meeting does not exist: FEtRDSUbQ3GKs8y0G3yLJg==.”}

Could you please advise what am I doing wrong?

1 Like

Hey @arjun.bsci,

When was that meeting created? I do not see that that meeting happened in our system in the last few months.

Thanks,
Tommy

Hello Tommy,
You can consider this meeting: https://api.zoom.us/v2/meetings/98607808189
“uuid” : “sm7+lAXSTHOhLqlwyK2y+g==”

When I hit API https://api.zoom.us/v2/past_meetings/sm7+lAXSTHOhLqlwyK2y+g==/participants
It gives same error
System.HttpResponse[Status=null, StatusCode=404] {“code”:3001,“message”:“Meeting does not exist: sm7+lAXSTHOhLqlwyK2y+g==.”}

I have tried to pass the UUID in double encoding form also but the same error. Could you please check. I can send you JWT token also if you want.

So I was fetching the Meeting UUID from API ‘/meetings/{meetingId}’, that’s why UUID was showing meeting doesn’t exist when I was trying to get participeants “/past_meetings/{meetingUUID}/participants”.

Now I have used API ‘/past_meetings/{meetingId}/instances’ to get Meeting UUID and receive the response.
Meeting ID:***********, MeetingUUID: xV77gvsdS/qyoxYkZ1OemA==

https://api.zoom.us/v2/past_meetings/xV77gvsdS/qyoxYkZ1OemA==/participants

The strange thing is one of the participants is showing twice in the response.

Response: System.HttpResponse[Status=null, StatusCode=200] {“page_count”:1,“page_size”:30,“total_records”:3,“next_page_token”:"",“participants”:[{“id”:“s8PmOOG_QDiDJF65rLI2Wg”,“name”:“Arjun Srivastava",“user_email”:"arjun.srivastava@bsci.com”},{“id”:“rxktD3y1STGb1TQP2ejhqg”,“name”:“aa ss",“user_email”:"an----4@gmail.com”},{“id”:“rxktD3y1STGb1TQP2ejhqg”,“name”:“aa ss",“user_email”:"an----4@gmail.com”}]}

Do you know why it showing the same person twice?

*This post has been edited to remove any meeting / webinar IDs

Hey @arjun.bsci,

Happy to hear you got the correct meeting UUID.

One of the reasons a participant will be shown twice, is if they joined the meeting, left, and then joined the meeting again.

Thanks,
Tommy

1 Like

hi

when I use this waDP0LgnRTe8Bm5TotjsvA%253D%253D meeting UUID to get polls from meeting using this report/meetings/waDP0LgnRTe8Bm5TotjsvA%253D%253D/polls Endpoint it is giving me 400 error can you please tell me what’s wrong in this?

Thank you

Hi @mitul.bhanushali,

Can you provide the original UUID not encoded, and an example of the full request URL you’re using? This will help me to debug.

Thanks!
Will

I have similar issue - cannot receive data for meeting with following UUID: REDACTED . I’ve been trying to put it as is, encode and double encode and nothing works.
I’m using this endpoint: https://api.zoom.us/v2/report/meetings/{meetingID}/participants

I’m getting response visible below:
{
“code”: 3001,
“message”: “Meeting does not exist: REDACTED”
}

What should I do?