"code":200,"message":"Account does not enabled REST API."


#1

Has anyone ever come across this error before? What can be changed about the account to enable REST? Thank you.


#2

Hi Michael, 

Could you give a some more details? Which API were you using and what parameters were you passing in?

Thanks

Michael


#3

Thanks Michael…here’s the code which I had found as an example online with the keys removed. I am running this code directly from the command line:

 

import time

import datetime

import requests

import jwt

 

KEY = 

SECRET =

 

header = {

“alg”: “HS256”,

“typ”: “JWT”

}

 

payload = {

“iss”: KEY,

“exp”: int(time.time() + 60)

}

 

token = jwt.encode(payload, SECRET, algorithm=‘HS256’, headers=header)

 

today = datetime.date.today()

yesterday = today - datetime.timedelta(1)

 

base_url = “https://api.zoom.us/v2/metrics/meetings

 

r = requests.get(’%s/?type=%s&from=%s&to=%s’ % (base_url, “past”, yesterday, today), headers={‘Authorization’: ‘Bearer %s’ % token})

 

print(r.content)

 

In addition to the error, I’m also getting this error which I haven’t researched yet:

 

SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. You can upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings

SNIMissingWarning

 

Thank you


#4

Also here is the  the API I’m trying to follow:

https://zoom.github.io/api/?shell#introduction


#5

Hi Michael, 

Can you send us your account ID along with the code base to developersupport@zoom.us so that we can further troubleshoot your issue?

Thanks


#6

Hello, thanks Michael, I did just send an email to developersupport with the requested info. Thank you for your help


#7

Hello, Just an update on this. This happens with both Python 2.7 and 3.0. For the account I mentioned in the email I sent to developersupport@zoom.us - does it not have the REST API enabled? Thank you


#8

I also encountered such a problem, how to solve it?


#9

Hi Michael, 

We have looked at your account and you do have REST API enabled. We have forward your code base and account details to the Engineers to troubleshoot your issue. 

Thanks


#10

Hi Rodger,

Would you be able to send your account details along with API’s you’re requesting to developersupport@zoom.us? From there we can look at your account and see if the Engineering team needs to troubleshoot.