Code 2013: Server to Server change from JWT

I’m implementing a Server to Server application to replace our current JWT. I receive the token just fine BUT any call that is made with that token receives the following response from Zoom:


"code": 2031,

"message": "Zoom Phone has not been enabled for this account."


The account that created the application is a Zoom Phone Admin and has S2S turned on (everything is turned on).

There are a bunch of similar issues on the Zoom forum but they all end with the requestor being contacted directly for some reason. Kind of defeats the purpose of the forum. Please advise.

Hi @jcorrente ,

Thanks for sharing this.

Sometimes there are account specific discrepancies that contribute to issues like this which is why you see this, and it may not be something that can be publicly rectified.

I’ll look into this and will message you for the user email which created the application, the production client id, the full request/response, and screenshot of the behavior you’re seeing.


This issue has been resolved:

If anyone else is here with the same issue it may be that you’re using the Master account endpoints unnecessarily. These endpoints have the additional string /accounts/{accountId} in the URLs and will yield errors if are not calling the endpoints from an enabled Master account with sub-account relationships:

Please use the non-Master account endpoints. In this instance, for example:

USE Zoom Phone API

DO NOT USE Zoom Phone Master API