Compliance Api returning `Invalid Request`

Compliance Api now rejecting our requests when they previously worked.

Which Endpoint/s?

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Receive de-auth notification from Zoom for an app
  2. Post the de-auth to compliance api
  3. Get invalid-request

Additional context
This api was really finicky before to get it to accept deauth requests and they only work the first time. If you post the same one a second time it fails so troubleshooting is extremely frustrating and tedious. Is there any way to pass back info to why the de-auth is failing? or get some help? I can supply the de-auth info in a DM if needed.

And yes I am adding the client id & secret as before when we were testing it and it worked.


Hey @zoom-test,

Can you share the log json from the request found here:

Feel free to DM me since there is sensitive info in the request. Or post here with the sensitive data redacted.


No Data

Maybe I should add more context. This is for an app we developed and published to the marketplace. One of the installers of the app (external to my zoom account/organization) deauthorized the app for them and then our server got the deauthorization webhook but the call we made to the compliance API failed. Does that url ( only show api requests made on behalf of my account for the app? Or would it show API requests made for any account outside of my own?

Hey @zoom-test,

Thanks for the context.

Do you happen to have the request body that was sent? So I can debug and try to reproduce.


I’ll DM you the contents.

1 Like

Thanks @zoom-test!