Components View "defaultViewType" not affecting anything

I see that your Meeting SDK embedded API offers an option to choose defaultViewType here:

But this doesn’t affect anything.

I’ve already seen people going towards very hacky unstable solutions here.

If you exposed the customizable property I believe you want it to work.

Using the embedded ZoomMtg:

import ZoomMtgEmbedded, { SuspensionViewType } from "@zoomus/websdk/embedded";

My Init snippet:

    await client.init({
      debug: true,
      zoomAppRoot: meetingSDKElement,
      language: "en-US",
      customize: {
        video: {
          popper: { disableDraggable: true },
          isResizable: false,
          defaultViewType: "gallery" as SuspensionViewType,
          // defaultViewType: SuspensionViewType.Gallery,
        chat: {
          popper: {
            disableDraggable: true,

Either an enum or string with a casting doesn’t change the result – nothing happens.
There are no errors in the console.
The meeting works fine but the default view is not applied.
Headers for ArrayBuffer are passed.

Please tell me if you need anything more from my side.

+1 We encountered this issue as well. defaultViewType doesn’t seem to affect anything. Also SuspensionViewType doesn’t seem to exist. Passing SuspensionViewType.Gallery breaks the compilation. Looking forward to a fix. Thanks! ,

Thank you for posting in the Zoom Developer. With regard to defaultViewType, the view should be set during the initialization process of the SDK. Can you share if that is what you are seeing on your end?

I pasted the snippet of the init call, you can see the defaultViewType set to “gallery” but the meeting starts in the ribbon mode No matter what value is set for defaultViewType it has no effect. The meeting always starts with the same view.

This is not a new issue as there is a bit older post here Zoom Component View not setting default view as gallery, no errors. Opens in ribbon view - #6 by linzblue5

I’ve already given examples and links in the original post, or I misunderstood your question?

I am using Typescript and the @zoomus/websdk is version 2.11.0.

@donte.zoom any update on the issue? It’s kinda blocking my client MVP launch :frowning:

Hi, and @SamA ,

I am not able to reproduce the described behavior on my end. When entering the meeting, Gallery View is the default view. Please see this walk-through video for reference :

Can you confirm if your site has sharedBufferarray enabled? If not, here is our support documentation on this topic:

Gallery View, Virtual Background, and 720p on web

Client Init Used in Demo Example

      debug: true,
      zoomAppRoot: meetingSDKElement,
      language: 'en-US',
      customize: {
        video: {
          popper: { disableDraggable: true },
          defaultViewType: "gallery",
        meetingInfo: ['topic', 'host', 'mn', 'pwd', 'telPwd', 'invite', 'participant', 'dc', 'enctype'],
        toolbar: {
          buttons: [
              text: 'Custom Button',
              className: 'CustomButton',
              onClick: () => {
                console.log('custom button');

Let me know if this helps.

Shared Buffer is enabled. Probably people that are having the same issue are using NextJS. It is the recommended framework right now by React so maybe you guys could create an example in NextJS.
That would probably help a lot and you could probably recreate the issue we are having.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.