Connection Refused when hitting zoom api

Description
*When i hit the zoom api it’s show me the connection refused error, either my app is working fine at localhost. i am facing this issue at live website. *

Error?
*cURL error 7: Failed to connect to api.zoom.us port 443 after 1157 ms: Connection refused *

API Endpoint/s?
https://api.zoom.us/v2/users?status=active&page_size=30&page_number=1

Hi @kmalik554
Hope you are doing great!
Are you still having this issue?

Hi @elisa.zoom thanks you for reply on my post. yes still i am facing this problem.

Thanks @kmalik554
Have you tried calling our API with postman?
What type of app are you using to call our API?

@elisa.zoom thanks for your kind response.

once i tried to call by postman it’s working fine.

once i try to call with my server then it’s through me this error. either it’s working fine on my localhost.

i am using laravel as a framework. also i am using JWT Token for calling API

Interesting @kmalik554
Have you tried generating the code snippet on postman and use it in your application?
I do not see why you are getting it to work on Postman and not within your app

You might want to check SSL protocol and cipher settings for HTTPS connections and allow the usage of ones that Zoom requires, especially if your production environment is older than your development environment — work with your server administrators to get this information and to troubleshoot. For example, .NET applications sometimes need to manually approve of TLS 1.2 by declaring it with ServicePointManager.SecurityProtocol.

Thanks @MultiplayerSession and @elisa.zoom for your response.

i have disable all the firewall on the server. i through that some firewall block my request but i my issue is remains.

same application when i run on my local environment then it’s working fine.

also i have check my ssl.

i am so worried about it. i need to be complete this task… :frowning:

What happens when you try to connect from the production server using OpenSSL?
For example: openssl s_client -connect api.zoom.us:443

Thanks @MultiplayerSession

i got your point. i just verify the TLS Version, we are using update TLS 1.3. and when i hit openssl s_client -connect api.zoom.us:443 it’s return me ssl certificate information

-----END CERTIFICATE-----
subject=/C=US/ST=California/L=San Jose/O=Zoom Video Communications, Inc./CN=*.zoom.us
issuer=/C=US/O=DigiCert Inc/CN=DigiCert TLS RSA SHA256 2020 CA1
---
No client certificate CA names sent
Peer signing digest: SHA512
Server Temp Key: ECDH, P-256, 256 bits
---
SSL handshake has read 4415 bytes and written 415 bytes
---
New, TLSv1/SSLv3, Cipher is ECDHE-RSA-AES256-GCM-SHA384
Server public key is 2048 bit
Secure Renegotiation IS supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
SSL-Session:
    Protocol  : TLSv1.2
    Cipher    : ECDHE-RSA-AES256-GCM-SHA384
    Session-ID: 7DB9BD07F58FE647324581A296E194A8FC3757E952FA078DE26101B10FA7F087
    Session-ID-ctx:
    Master-Key: 81304F346F03A342560E36421B5055D87C3701CD4BDBF268FB3168F531C99C531011C1AA2229775EAB2D86932D144FBD
    Key-Arg   : None
    Krb5 Principal: None
    PSK identity: None
    PSK identity hint: None
    Start Time: 1656568688
    Timeout   : 300 (sec)
    Verify return code: 0 (ok)

and when i hit for my now domain it’s also return me

 Start Time: 1656568928
    Timeout   : 300 (sec)
    Verify return code: 0 (ok)

other information hide for security purpose. but it also valid ssl…

Is any firewall problem from our side?
or
would Zoom whitelist my domain/IP at Zoom Server?

Sounds like you were able to establish a connection using OpenSSL from your production server to Zoom, but your application code cannot from the same server. Then you’ll want to compare how your application is negotiating a connection versus how OpenSSL is negotiating a connection; are there any differences in supported ciphers or protocols? I’m not familiar with your technology stack, so you’ll have to research how to do this for your environment.