Contacts status "offline" in ZR-CSAPI zCommand Phonebook List

All contacts have status “offline” when execute “zCommand Phonebook List”

How To Reproduce (If applicable)
I have a setup with custom control interface through ZR-CSAPI which control ZoomRoom for Windows. When ZoomRoom starts, I get all contacts in offline status from command “zCommand Phonebook List”. If I close custom interface, starts original ZoomRoom App all contact statutes updated. After that, custom interface with command “zCommand Phonebook List” works as should be .

Looks like ZoomRoom after restart doesnt begin update contact status until original ZoomRoom App connected. Once it connected it works fine.

Hi @Raz1988,

Thank you for reporting this issue to us. I have forwarded your concerns to our Engineering so that they can investigate more on this. I will respond back to you as soon as I get any updates from them.

As of now, we do not provide Zoom Room Support on this forum, but we highly encourage our customers to reach out to us on with questions, and we will assist you in the best possible manner.

Let me know if you have any other questions.


Hi Ojus,

Any news from your Engineering team?

Hi @Raz1988,

I am sorry for the inconvenience that this is causing. This issue is still in our backlog to be worked on. We haven’t had the chance to put this in a release yet, you can follow our release log here.

I am also monitoring this personally, and will respond to you as soon as I have any updates. The id for this within our system is ZOOM-102856.

Let me know if you have any other questions.


I’m sorry to revive this topic, but is there a chance this has not been resolved? I seem to encounter the same bug.

Hi Alexander.
I’ve got email from Ojus below, but actually the problem is still here.
Sovetuyu zabit’ na ih API potomu chto schitayu ego syroy podelkoy, kotoroy bolshe nikto ne zanimaetsa. Look at Room Control feature instead.

Hi there,

Thank you for patiently waiting as we were trying to fix the issue.

I can confirm that the engineering team has fixed the issue. From now, you will need to use a new command to subscribe to the status.

Here is the syntax: zCommand Phonebook Subscribe offset : limit :

To know more about this command, please visit:

Please let me know if you have any additional questions. Once again thank you for being a valued customer at Zoom.

1 Like

Many thanks @Raz1988! I will try as Ojus suggested.

Room Control feature is not an option for me, because I need to control Room software programmatically, not external devices. Or am I missing something and Room Control can be helpful for me?

Hey @alexander.zarubkin, @Raz1988,

Since the issue in the original thread has been resolved, can you please create a new one here: #zoom-api and fill out the template so we have enough information to help?