Create a session to create a room in Java Android

I have no idea if I’m getting this wrong, but first I created my zoom credentials so I could create an app, here tell to Import the SDK Libraries, with this, i downloaded the SDK, installed mobilertc in my project, with this here, it says to be able to create the sessions.

ZoomVideoSDKSessionContext params = new ZoomVideoSDKSessionContext();
params.sessionName = “My Session”;
params.userName = “My Name”;
params.token = “”; // TODO: Pass in your JWT

but in the folder mobilertc don’t have *ZoomVideoSDKSessionContext*

Where is it wrong?

Hi @gabrielfaleri ,

After importing the mobilertc folder into your android application, here are some additional steps.

  1. add mobilertc as a dependency for your android app (module settings in android studio)
  2. sync project with gradle files
  3. import us.zoom.sdk.ZoomVideoSDKSessionContext in the java class which you are using ZoomVideoSDKSessionContext object

Hi @chunsiong.tan.

Thank you for your answer, but don’t resolved

I follow all the additional steps but show me this error

setting.gradle

pluginManagement {
    repositories {
        gradlePluginPortal()
        google()
        mavenCentral()
    }
}
dependencyResolutionManagement {
    repositoriesMode.set(RepositoriesMode.FAIL_ON_PROJECT_REPOS)
    repositories {
        jcenter()
        google()
        mavenCentral()
    }
}
rootProject.name = "TestZoom"
include ':app'
include ':mobilertc'

build.gradle


plugins {
    id 'com.android.application'
}

android {
    compileSdk 32

    defaultConfig {
        applicationId "com.kornerz.testzoom"
        minSdk 23
        targetSdk 32
        versionCode 1
        versionName "1.0"

        testInstrumentationRunner "androidx.test.runner.AndroidJUnitRunner"
    }

    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android-optimize.txt'), 'proguard-rules.pro'
        }
    }
    compileOptions {
        sourceCompatibility JavaVersion.VERSION_1_8
        targetCompatibility JavaVersion.VERSION_1_8
    }
}

dependencies {

    implementation 'androidx.appcompat:appcompat:1.5.1'
    implementation 'com.google.android.material:material:1.7.0'
    implementation 'androidx.constraintlayout:constraintlayout:2.1.4'
    implementation project(path: ':mobilertc')
    testImplementation 'junit:junit:4.13.2'
    androidTestImplementation 'androidx.test.ext:junit:1.1.4'
    androidTestImplementation 'androidx.test.espresso:espresso-core:3.5.0'
}

I Download the SDK from Meeting SDK

Stay right?

P…S. The download only works after I add the jcenter in settings.gradle, show me: Failed to resolve: com.google.android:flexbox:2.0.1: Add Google Maven repository and sync project

If you encounter error the above mentioned error, you might need to

  1. remove this code block in settings.gradle
dependencyResolutionManagement {   

repositoriesMode.set(RepositoriesMode.FAIL_ON_PROJECT_REPOS)    
    repositories {
                  google()
                  mavenCentral()
                  maven {
                         url 'https://jitpack.io' }
                 }
    }
  1. add this code block to build.gradle
allprojects {
    repositories {
        google()      
        jcenter()
        maven {
            url 'https://maven.google.com/'
            name 'Google'
              }
        }
    }

Hi.

Dont work…

This ZoomVideoSDKSessionContext it’s about videosdk from here?

Thanks

@gabrielfaleri are you using meeting sdk or video sdk?