Create meeting API - UTC timezone is not returning correct response

Description
Create meeting api- when we try to create a meeting by passing timezone value as “UTC” along with the start time value, then the API response returns the value of “start_time” in local time. Instead it should return the “start_time” in UTC.
Can you please let me know, if this behavior is correct?

Which Endpoint/s?
Create meeting Api.

How To Reproduce (If applicable)
Steps to reproduce the behavior:
[REDACTED]

As per me the start_time value should be 2021-05-28T10:00:00Z(UTC conversion for the the passed start_time in request)

Hi Team,

Any updates on above request?

Hey @deepali.necti,

Thank you for reaching out to the Zoom Developer Forum. When you are telling Zoom the timezone, you are setting the time to 2021-05-28T16:00:00Z UTC. If you expect that to be a different time in UTC or any other timezone, it should be set when making the API request. The response will not convert to local time.

Thanks,
Max

Thanks for the response @MaxM .

All I want to know is that how can I create a meeting in UTC time zone using create meeting api. Can you please respond on below:

  1. Do I have to pass start_time value in UTC during the request?
  2. Or does the zoom server converts the request start_time to UTC format while creating a meeting?

Hey @deepali.necti,

Thanks for clarifying the question!

When you set a start_time it follows the below rules in regard to the timezone:

image

Therefore, you just need to set the start_time to “2021-05-28T16:00:00Z” to achieve your goal of setting the time in UTC.

However, let’s say you wanted make the start time of the meeting 3 AM MT. You would set start_time to “2021-05-28T16:00:00” and then set timezone to “America/Denver”.

When the created meeting is returned, the time will be shown in the UTC timezone regardless of what you set:

image

Let me know if that helps.

Thanks,
Max

Thanks @MaxM ,

I will try above approach and will let you know, if I require any other information.

Hey @deepali.necti,

I’m glad that was helpful, please do let me know if you have any questions or issues going forward.

Thanks,
Max