Create Meeting with Room

Description
I am writing a Windows Service to auto create meetings in rooms (Classroom schedule)
I am able to create the meeting for the user or the room and verify with api that the meeting is created
When I create for the user, the meeting is seen his scheduled meeting list

Error
The Issue is that the meeting do not appear ion zoom room list
To Correct this I Updated the meeting with schedule_for parameter and now the meeting is still in users schedule meeting list with the host changed to the ROOM name
However still the room controller does not display the meeting ion the list

HOw do I Include the room in the meeting with this API so that the room controller becomes aware of the meeting?

Which App Type (OAuth / Chatbot / JWT / Webhook)?
JWT

Hey @e.rajeev, thanks for posting and using Zoom!

Which API endpoints are you using to create the meeting in the Zoom Room?

Thanks,
Tommy

Hi Tommy,
The re is only one enpoint mentioned for create meeting
For Create Meeting I am using
{{baseUrl}}/users/:userId/meetings

For update Meeting I am Using
{{baseUrl}}/meetings/:meetingId

There seems to be 2 IDs for Zoom rooms (Assumption)

  1. The Actual Room ID (as received List Zoom rooms in metrics)
  2. The Zoom room user Id (as received from List Zoom rooms in rooms)

The Id I am using to create a meeting is from Option 2 from above

regards

Hey @e.rajeev,

Can you try creating the meeting via our Zoom Room APIs? They should appear on the display.

Thanks,
Tommy

Thanks Tommy,
I tried Scheduling an new Meeting and Scheduled a Meeting with meeting info set to a previously created meeting created with Create Meeting endpoint.
In both cases the api returned success but no meeting was seen in Zoom room display
The response to the scheduling of an exisitng meeting is as below
{
“jsonrpc”: “2.0”,
“result”: {
“room_id”: “ZejAlSBhSCebU1doaLdkSA”,
“send_at”: “2020-02-08T07:50:19Z”
},
“id”: “0a1a92d8-8c34-4e43-9dd1-2e9e68bc51f2”
}

I guess Calendar Integration is the way to go :pensive:

Hey @e.rajeev,

Do you have a calendar service linked to your Zoom Room? If not, can you try adding one and see if that fixes it:

Thanks,
Tommy

Dear Tommy,
Thanks.

I do have a calendar linked to room in Question. (Though all rooms do not have a calendar on which work is in progress)

If I create a meeting on the Calendar (Exchange) the meeting does appear on the Zoom meeting controller and scheduling Display.

however if I create a meeting with the zoom api, the calendar is not updated, neither the zoom room displays it

Thanks again for the prompt responses
Rajeev E

Hey @e.rajeev,

We will look into this to see if there is a bug and get back to you. (ZOOM-138196)

Can you provide the request body you are sending?

Thanks,
Tommy

HEy,
It is working now (Scheduling through room API) See further below the Body I sent and the response
The Only difference is that I added Impersonation role/rights to the user ID (used in Calendar Configuration) in Exchange. Could this be the difference
The Body I sent
{
“jsonrpc”: “2.0”,
“method”: “schedule”,
“params”: {
“meeting_info”: {
“topic”: “CRN 201920-78906”,
“agenda”: “CRN 202001-24567”,
“start_time”: “2020-02-16T22:00:00”,
“timezone”: “Asia/Dubai”,
“duration”: “10”,
“settings”: {
“host_video”: true,
“participant_video”: false,
“cn_meeting”: false,
“in_meeting”: false,
“join_before_host”: true,
“mute_upon_entry”: true,
“watermark”: false,
“use_pmi”: false,
“approval_type”: 0,
“registration_type”: 1,
“audio”: “both”,
“auto_recording”: “cloud”,
“enforce_login”: false,
“enforce_login_domains”: “”,
“alternative_hosts”: “Rwp4FXnPQ8e-iHj1k3tbvQ”
}
}
}
}

The response I received
{
“jsonrpc”: “2.0”,
“result”: {
“room_id”: “ZejAlSBhSCebU1doaLdkSA”,
“send_at”: “2020-02-16T17:01:44Z”
},
“id”: “5881ad96-9e8f-4306-8ca2-a26a034bf82e”
}

Challenge is How do I use the GUID in the response to Identify the meeting and its recording/participants etc.

Thanks again

One Issue Though,
The Topic on the Scheduling Display was the Name of the Account which has the full access to the calendar. The Topic was correct till I switched on the Scheduling display.

On exchange I see that the meeting host is the Calendar admin account not the room calendar!!
I doesn’t really matter who the host is (for this application) but

  1. Meeting Number / uuid is nowhere to be seen
  2. The Scheduling display Shows the host name, but not the Topic used in Scheduling the meeting

Expecting your prompt response as always,
Thanks again

Rajeev E

Hey @e.rajeev e.rajeev,

Can you use the Zoom Rooms personal meeting number to link it?

Also can you try using the Meeting Creating Webhook to identify the meeting?

That is strange. Can you reach out to support.zoom.us for this? They will be able to help with Zoom Room specific functionality.

Thanks,
Tommy

Thanks a lot Tommy,
I’ll be travelling for couple of days. So I’ll check these things and get back to you by next week

As of now My Approach is to

  1. Create a meeting in Zoom with hot as the person who conducts the meeting
  2. Add a meeting in the Zoom room calendar (on Exchange) with location as the meeting join URL
  3. Invite the actual host, and other room participants to the meeting
    a. which adds the meeting to their calendar as well, but with Topic as the main room name

This scenario works well for me.

I would like to try web hooks, but I do not really have a URL to post in public internet since my app is a service. I have gone through the documentation but the whole Zoom Marketplace app scenario creates a lot of doubts about the actual workflow.

Is there somewhere I can call and Quickly clear my queries (quite a few of them - too voluminous to type up :frowning: )

Thanks and Regards,

1 Like

I shoudl note here that I’m impressed (for whatever its worth) of

  1. The Quick responses!
  2. The ability to not go back to too many basics
    a. I’ve learned new stuff from the interaction, never had I heard some thing which was already in documentation (at least the parts I read)

:slight_smile:

Thanks a lot

1 Like

Hey @e.rajeev,

You can have a Private Webhook app that does not need to be published to the Zoom Marketplace.

Good approach, we plan on making this flow easier this year with our APIs.

Happy to answer your questions further over a Zoom Meeting:

Also, thanks for the compliments! :slight_smile:

-Tommy

Hey @e.rajeev,

If you are still having issues, can you please upgrade the ZR app, recreate the issue, and send us the logs from the room?

From the web portal: Log into the company admin account; Click the “Edit” button of the appropriate Zoom Room → “Room Settings” tab → Room Profile → Any problem? Click here to send problem to us (make sure the room is online to see this option)

Thanks,
Tommy