Create/Update Monitoring group seemingly ignores "Prompt" property

Creating or Updating a monitoring group endpoints seemingly ignores the “prompt” property when sending the request?

Hi @ctc.aaron
Thanks for reaching out to us!
Could you please share with me the request body you are sending so I can try and replicate this issue on my end?

Sorry for late reply, I just don’t check here often because this forum is mostly a waste of time. :frowning:

My C# Wrapper that I wrote works flawless for so many functions across many of the endpoints within Phone and Meeting apis but this is one of the few that seemingly ignores part of the body. Not sure if this is just a problem in your documentation or problem in the design.

Method: POST

  "name": "Testing Something",
  "site_id": "<SITEID>",
  "type": 1,
  "monitoring_privileges": [
  "prompt": false

Which results in this group ( I manually added a monitor so you can see the privileges were applied correctly and not ignored either ):

Thanks @ctc.aaron
I was able to replicate this issue on my end.
I will go ahead and report this issue to our Engineering team so they can look into this.
In the meantime, I found a workaround.
After creating the monitoring group, you can make an extra API call for a PATCH request and you can pass the value “prompt” as false and this will change that setting

1 Like

I created an internal ticket for this issue ( ZSEE-114823 internal number for reference)
This has been identified as a bug on our end and it will be fixed in a later release. In the meantime please use the workaround I suggested to make sure the Prompt is set to the value you want.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.