Create webinar is not working

create webinar is not working with default example json

“code”: 300,
“message”: “Request Body should be a valid JSON object.”

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Which Endpoint/s?{userId}/webinars

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Request url -{userId}/webinars
  2. Add userid, oauth access token
  3. copy the example json and post it
  4. See error

Hey @srini.adepu,

This error means your request body is malformed.

Please share your request body JSON so I can debug.


“topic”: “Test Webinar”,
“type”: 5,
“start_time”: “2020-09-20T06:59:00Z”,
“duration”: “60”,
“timezone”: “America/Los_Angeles”,
“password”: “avfhfgh”,
“agenda”: “Test Webinar”,
“recurrence”: {
“type”: 1,
“repeat_interval”: 1,
“end_date_time”: “2020-09-20T06:59:00Z”
“settings”: {
“host_video”: “true”,
“panelists_video”: “true”,
“practice_session”: “true”,
“hd_video”: “true”,
“approval_type”: 0,
“registration_type”: “integer”,
“audio”: “both”,
“auto_recording”: “none”,
“enforce_login”: “false”,
“enforce_login_domains”: “”,
“alternative_hosts”: “”,
“close_registration”: “true”,
“show_share_button”: “true”,
“allow_multiple_devices”: “false”,
“registrants_email_notification”: “true”

Hey @srini.adepu,

Simple mistake, for the "registration_type" you have the String "integer" as the value.

The "registration_type" must be of type Integer, 1, 2, or, 3.

Although, since you have "approval_type" set to 0 which means automatically approve, you don’t even need the "registration_type" property.

Screen Shot 2020-01-14 at 10.52.02 AM

Here is the correct JSON:

  "topic": "Test Webinar",
  "type": 5,
  "start_time": "2020-09-20T06:59:00Z",
  "duration": "60",
  "timezone": "America/Los_Angeles",
  "password": "avfhfgh",
  "agenda": "Test Webinar",
  "recurrence": {
    "type": 1,
    "repeat_interval": 1,
    "end_date_time": "2020-09-20T06:59:00Z"
  "settings": {
    "host_video": true,
    "panelists_video": true,
    "practice_session": true,
    "hd_video": true,
    "approval_type": 0,
    "audio": "both",
    "auto_recording": "none",
    "enforce_login": false,
    "enforce_login_domains": "",
    "alternative_hosts": "",
    "close_registration": true,
    "show_share_button": true,
    "allow_multiple_devices": false,
    "registrants_email_notification": true


Thanks for the quick response.

I dont have registration type field in my json file.

Hey @srini.adepu,

In the JSON you shared, you do: