Daylight Changes are starting our already scheduled meetings 1 hour ealrier

Description
Our already scheduled meetings through zoom api are now showing the start time of 1 hour earlier. To create the meeting and setting the time zone, we are using the following code.
SimpleDateFormat sdf = new SimpleDateFormat(“yyyy-MM-dd’T’HH:mm:ss’Z’”, Locale.US);
sdf.setTimeZone(TimeZone.getTimeZone(“America/New_York”));
We are in EST.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
We are using OAuth for Code

Which Endpoint/s?
https://api.zoom.us/v2/users/" + hostid + "/meetings

Screenshots (If applicable)

This meeting was actually scheduled for 10 AM. But was scheduled before the day lights changes came into effect.

Hi @garima,

Can you make sure your system time is properly synced and make sure the time syncs with world time?

  1. Example of syncing your machine time using window 10
    e1b2c451-e93c-4238-b464-ead68f8cca69

Example for using Mac

Let me know if this helps—thanks!
Will

Our system time is in Sync with the clock. When we click on zoom link generated with create meeting, it shows the time 1 hr before than the actual scheduled one.

Hey @garima,

What timezone did you create your meetings in?

Can you please provide your request body JSON for creating your meetings?

Thanks,
Tommy

String rest_url = “https://api.zoom.us/v2/users/” + hostid + “/meetings”;
SimpleDateFormat sdf = new SimpleDateFormat(“yyyy-MM-dd’T’HH:mm:ss’Z’”, Locale.US);
sdf.setTimeZone(TimeZone.getTimeZone(“America/New_York”));
String starttime_timestamp_zoom = sdf.format(new Timestamp(start_time));
String jsonString = “{“topic”:”" + event.getEventtypename() + “”,“type”:“2”,“start_time”:""
+ starttime_timestamp_zoom + “”,“duration”:"" + duration + “”
+ “”,“passcode”:“true”,“agenda”:“Training”,“settings”:{“host_video”:“true”,“participant_video”:“true”,“cn_meeting”:"
+ ““false”,“in_meeting”:“false”,“join_before_host”:“false”,“waiting_room”:“false”,“mute_upon_entry”:“false”,“watermark”:”
+ ““false”,“use_pmi”:“false”,“approval_type”:“0”,“registration_type”:“1”,“registrants_email_notification”:”
+ ““true”,“alternative_hosts”:”" + alternate_hosts + “”}}";

Hey @garima,

Can you share the actual values you are passing in? We need all of this so we can attempt to reproduce the issue.

Thanks,
Tommy