De-activating JWT causes error in server-to-server

de-activating JWT causes error in server-to-server

Account does not enabled REST API.

How To Reproduce
Steps to reproduce the behavior:
deactivate JWT
authenticate with Server-to-Server
view errror

I migrated our code per the migration guides from a JWT app to a Server-to-Server app. My code only calls the Server-to-Server app and uses the clientID and client secret from the Server to Server app (not from the JWT app) and uses the Server-to-Server endpoint

However when the JWT app is de-activated the Server-To-Server app breaks with

{“code”:200,“message”:“Account does not enabled REST API.”}.

Please advise.

and when I re-activate the JWT app then the Server-to-SErver app works again… even though as I said all my code has been remediated to only use Server-to-Server clientId, client secret and a different endpoint for authentication -

Makes no sense yet :slight_smile:

Hi @davisg1
Thanks for reaching out to us ! I am happy to look into this.
I will send you a private message to get more information about your account so I can investigate this further!