Delete User API is not transferring meetings

Delete end point is not moving the meetings to new user. Here is the body content

{ “action”: “delete”, “transfer_email”:“”, “transfer_meeting”: true, “transfer_webinar”: true, “transfer_recording”: true }

NO, error was returned, deletion is successful.

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Which Endpoint/s?{userID} DELETE method

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Request URL / Headers (without credentials) / Body
  2. See error

Screenshots (If applicable)
If applicable, add screenshots to help explain your problem.

Additional context
It appears many people raised this concern in last year, I am not the first one. No where I found the response, instead tickets are closed.

Hi @svoruganti1,

Thank you for reaching out about this, and happy to help.

To clarify, are you specifying the disassociate or delete parameter in your request URL? Can you share the full request URL you’re using? Additionally, can you confirm that the user you’re deleting has active meetings/data to transfer?

Let me know—thanks!

Thank you Will for quick response.

Here is the screenshot

Here is the java code:

con = (HttpURLConnection) url.openConnection();
		con.setRequestProperty("Authorization", token);
		con.setRequestProperty("Content-Type", "application/json");
		OutputStreamWriter out = new OutputStreamWriter(
		String writeString = "{ \"action\": \"delete\","
				+ " \"transfer_email\":\"\","
				+ " \"transfer_meeting\": true,"
				+ " \"transfer_webinar\": true,"
				+ " \"transfer_recording\": true }";


Hi @svoruganti1,

Can you please confirm that you’re passing the necessary parameters as part of the request URL and not as part of a request body? Note that these should be query parameters, this request has no body:

I see that you referenced body content in your original post.

Let me know if you still have issues after making this adjustment.


Thanks Will, it worked with query/request parameters, tested with postman.

After the deletion when I try to re-create the same user from Admin login so that I can test from my Java code ran into following error. Doesn’t give more details simply says data error and asked me to contact Zoom. Please see the screenshot below, can you please help me what is going wrong?

Hey @svoruganti1,

Can you please share these details/screenshot with our Technical Support team here? They will be be best suited to troubleshoot this error and help resolve.


Thanks Will,

I called the customer support, they helped me figure-out.

Here is what happened:
Upon the deletion account with that email became basic, when I use the same email to send invitation is not working from company account (add user). Instead I signed up as a basic user with the same email then I received activation link, and I activate the zoom basic, then as an admin from company account I invited the user, then It worked.

Also, I noticed, when I used transfer_webinar = true, request is failing, I realized webinar is different subscription we don’t have. When I removed this parameter, deletion was successful.

Thank you again for your help.

Hey @svoruganti1,

I’m glad to hear that they resolved your issue! Thank you for posting the solution here. Please don’t hesitate to reach out if you encounter any further issues or questions.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.