Discussion crash on joining webinar in iOS Meeting sdk version and above

I recently upgraded my application to zoom meeting sdk to , meeting work properly but while running webinar (Joining webinar) app crashes with following log

-[ZPAlertViewMgr showAutoRegisterWebinarAlert]: unrecognized selector sent to instance 0x2824a2460
*** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘-[ZPAlertViewMgr showAutoRegisterWebinarAlert]: unrecognized selector sent to instance 0x2824a2460’

I tried one version below and it is working fine however every version above is crashing with the same log

Which iOS Meeting SDK version?

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Join webinar (To be precise I am using code shown in build your app section and webinar doesnot have password)

Smartphone (please complete the following information):

  • Device: ipad
  • OS: ipadOS 16.2


Thank you for posting in the Zoom Developer Forum. I’m happy to help. To begin, could you please let me know if this issue can be replicated using the latest versions of the iOS SDK? Additionally, can you provide the exact steps to reproduce this behavior? Once I receive this information, I will work to reproduce the issue on my end and submit a bug ticket if necessary.

I should also note, with the lastest version of iOS SDK, there is a new requirement. To learn more, please see this forum post:

Thanks for the reply @donte.zoom. Below I have provided details of my integration of zoom sdk

this is my implementation which I replicated from the zoom tutorial page and is working below 5-13-10-7064 but from 5-13-10-7064 and above the meetings are working fine but webinar is crashing.

For the steps to reproduce the crash:

  • Use webinar Id and my webinar does not have password so empty password field (i.e., password=" ").
  • Then, join the webinar

I have the same error “Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: '-[ZPAlertViewMgr showAutoRegisterWebinarAlert]”, I update the SDK to the latest version

@Bishal Did you find the solution?


Hey all!

I am able to replicate this issue when a “no registration required” webinar is created and I am currently checking with our engineers.
I will get back as soon as possible once I have more information.

As for the “registration required” webinar, do note that you will need to also add in the webinarToken field when you create the MobileRTCMeetingJoinParam variable.

Thank you.

No @bargasjavier as per my research there is something wrong with showAutoRegisterWebinarAlert method in ZPAlertViewMgr class (which is problem in SDK itself). Lets wait for the reply from @boonjun.tan for the solution.


Hi @Bishal and @bargasjavier,

Thank you all for your patience. I have confirmed this issue with our Engineering team, and it will be fixed in the upcoming release.

1 Like

Hi, do we have an ETA for the next release? We are facing the same issue.

We’re getting a spike in our crash rate, we’re running iOS SDK @boonjun.tan is there an ETA for this fix?

Fatal Exception: NSInvalidArgumentException
-[ZPAlertViewMgr showAutoRegisterWebinarAlert]: unrecognized selector sent to instance 0x2834ad680

Hi @it115 and @henrique,

This should be fixed in the upcoming release of version 5.14.10 onwards at the end of this month. In the meantime, I do suggest making use of Webinar which requires registration before the fix.

Thank you.

Hi @Bishal, @bargasjavier, @it115 and @henrique,

Good news! We have released our latest Meeting SDK version 5.14.10 today and it contains the fix for this issue.



Thank you @boonjun.tan

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.