Does meeting requests per day rate limits include DELETE meeting?

Using this template helps us debug your issues more effectively :slight_smile:

Description

A single user can only make 100 create, update, or delete meeting requests per day (UTC).

I checked X-RateLimit-Limit in DELETE meeting response headers .

X-RateLimit-Limit 6000

DELETE meeting reference page doesn’t have explanation about “Daily meeting create and update requests” rate limits.

Which is the correct?

Error

Which App Type (OAuth / Chatbot / JWT / Webhook)?
OAuth

Which Endpoint/s?

How To Reproduce (If applicable)

Screenshots (If applicable)

Additional context

Hi @yuki333 ,

Thanks for pointing this out! I’ll inquire further on your behalf!

Best,
Gianni

Hi, @gianni.zoom .

Did you get an answer?

Hi @yuki333 ,

Yes here is the most up to date info for your inquiry:

Thank you,
Gianni

1 Like

Hi, @gianni.zoom

We want to know which one is wrong?
Is the “X-RateLimit-Limit 6000” count in the DELETE API response header a bug?

Thanks

Hi @yuki333 ,

It should be 100 per user with Create/Update rights. How many accounts do you have with access rights to this API endpoint?

Thank you,
Gianni

1 Like

Hi, @gianni.zoom

I have 1 account that has 1 user.

I understand that the rate limit for Create/Update is 100. Because the “x-ratelimit-remaining” in the response header of the Create/Update meeting is decreased from 100.
But Delete API is decreased from 6000.

My curl verbose response by Delete API is below. We can see that “x-ratelimit-limit” is 6000 and “x-ratelimit-remaining” is 5999.
So I think it is decreased from 6000.
However, according to the documentation, the limit of 100 includes delete meetings by the API.

A single user can only make 100 create, update, or delete meeting requests per day (UTC).

I’m sorry my English is not good enough.

curl -v --location --request DELETE 'https://api.zoom.us/v2/meetings/96039xxxxxx' \
der 'Co> --header 'Content-Type: application/json' \
> --header 'Authorization: Bearer xxxxx'
*   Trying 52.202.62.238:443...
* TCP_NODELAY set
* Connected to api.zoom.us (52.202.62.238) port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* successfully set certificate verify locations:
*   CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: /etc/ssl/certs
* TLSv1.3 (OUT), TLS handshake, Client hello (1):
* TLSv1.3 (IN), TLS handshake, Server hello (2):
* TLSv1.2 (IN), TLS handshake, Certificate (11):
* TLSv1.2 (IN), TLS handshake, Server key exchange (12):
* TLSv1.2 (IN), TLS handshake, Server finished (14):
* TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
* TLSv1.2 (OUT), TLS change cipher, Change cipher spec (1):
* TLSv1.2 (OUT), TLS handshake, Finished (20):
* TLSv1.2 (IN), TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / ECDHE-RSA-AES256-GCM-SHA384
* ALPN, server accepted to use h2
* Server certificate:
*  subject: C=US; ST=California; L=San Jose; O=Zoom Video Communications, Inc.; CN=*.zoom.us
*  start date: May 24 00:00:00 2020 GMT
*  expire date: Jun  1 12:00:00 2022 GMT
*  subjectAltName: host "api.zoom.us" matched cert's "*.zoom.us"
*  issuer: C=US; O=DigiCert Inc; CN=DigiCert SHA2 Secure Server CA
*  SSL certificate verify ok.
* Using HTTP2, server supports multi-use
* Connection state changed (HTTP/2 confirmed)
* Copying HTTP/2 data in stream buffer to connection buffer after upgrade: len=0
* Using Stream ID: 1 (easy handle 0x562a5cc83860)
> DELETE /v2/meetings/96039199285 HTTP/2
> Host: api.zoom.us
> user-agent: curl/7.68.0
> accept: */*
> content-type: application/json
> authorization: Bearer xxxxx
>
* Connection state changed (MAX_CONCURRENT_STREAMS == 128)!
< HTTP/2 204
< date: Wed, 24 Nov 2021 01:19:28 GMT
< x-zm-trackingid: v=2.0;clid=aw1;rid=WEB_fcafc276fb562550dcea1f13267bd4d8
< x-content-type-options: nosniff
< cache-control: no-cache, no-store, must-revalidate, no-transform
< pragma: no-cache
< expires: Thu, 01 Jan 1970 00:00:00 GMT
< vary: Origin
< vary: Access-Control-Request-Method
< vary: Access-Control-Request-Headers
< x-ratelimit-category: Light
< x-ratelimit-limit: 6000
< x-ratelimit-remaining: 5999
< x-zm-zoneid: VA
< strict-transport-security: max-age=31536000; includeSubDomains
< x-xss-protection: 1; mode=block
< referrer-policy: strict-origin-when-cross-origin
<
* Connection #0 to host api.zoom.us left intact

Thank you.

Thank you for this @yuki333 , we will look into this and see what is happening here!

1 Like

Hi @yuki333 ,

I’m not able to reproduce the response you’re seeing so I am waiting to hear back some thoughts from our API team about this. Thank you for your patience.

Gianni

1 Like

Hi, @gianni.zoom

How is this matter going?
Thank you.

Hi @yuki333 ,

It should be a daily limit of 100 as you identified before, but we need to look into your account further to see why you’re receiving the limits you see in the headers. Could you please private message me your email address and the full API request details that you made please?

Thank you!

Hi, @gianni.zoom

How can I send a private message?
Thank you.

Hi @yuki333 if you click on my username you should see an option to send me a message.

Hi, @gianni.zoom

I couldn’t find a option.

I googled and read this topic

So I check in my preferences page also, but there’s nothing like that…

If it is possible, could you please send me a message first one?

Thank you.

Hi @yuki333,

I just messaged you. If it does not work, you can send the info to developersupport@zoom.us, directed to me :slight_smile:

Hi, @gianni.zoom

I replied with full log.

Thank you!

Hey @yuki333,

Thank you for submitting a ticket! We’ll be sure to follow up with you there.

Thanks,
Max