Embed password in zoom cloud recording play link?

Issue with updating recording settings. My request body has share_recording=‘publicly’ and password=’’.

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Which Endpoint/s?
PATCH /meetings/{meetingId}/recordings/settings

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Body sent with the PATCH request
    “share_recording”: “publicly”,
    “recording_authentication”: false,
    “viewer_download”: false,
    “on_demand”: false,
    “password”: “”
  2. Error response
    “code”: 300,
    “message”: “Validation Failed.”,
    “errors”: [
    “field”: “password”,
    “message”: “The password you entered does not meet the password requirements.”

Additional context
Since share_recording publicly seems to require password, I was wondering if there is a way to embed the password in the play_url somehow so the users will be able to play the recording directly when we deliver them the link through API?


We are also facing same issue

Earliest blank password used to work.
There is some change from Zoom’s end so now API doesn’t allow blank password field.
We have kept the required password setting disabled and locked at the account level.

Still it requires password while changing settings via API.
The strangest things are:

  • The API accepts 8 and 9 character passwords and not larger than that
  • When we set the settings from admin panel for a particular recording, it accepts disabling password for that recording
  • The most strange thing is when we query the settings for this recording, the GET API returns blank password

This has broken down our entire flow. On an urgent basis, we have to set some common password for all recordings and share it publicly with all. This is so counter-productive.

Hey @gourav.ims, @yuvarajg, @datta,

Here are some updates around passwords:

Cloud recordings: Password protection for shared cloud recordings is now on by default for all accounts. We’ve also enhanced the complexity of passwords on your cloud recordings. Existing shared recordings are not affected.”

As pertains to the API:

Let me know if you are able to resolve the issue.


Yes, this works.

1 Like

Happy to help! :slight_smile: