Embed Zoom into Website

@tommy i user iframe code "<iframe src="https://zoom.us/wc/{{WebinarID}}/join?prefer=1&un=VkhNIEFkbWlu&uel={{base64EncodedEmail}}" sandbox="allow-forms allow-scripts" allow="microphone; camera; fullscreen"></iframe>
"
the result will be joining webinar screen loading and not join to webinar also i have console errors

Hi, trying to embed into a joomla content page, using the below, user has to login. Trying to avoid this and go straight to the video, the content page will be restricted to logged in users only so don’t really want them to have to login again.

Secondly, the whole page is in the iframe includiong header and footer of zoom website, would be good to just show the actual video. Is this possible?

Incidentally, once logged in through the iframe, the meeting does show ok.

Using:

Hi @tommy,

We have a parameter to password (pwd) and to a name (un), is there any one for email?

I need to ember a Zoom Webnair and I’ve got this page:

I currently modify the parameter prefer=1 to prefer=0 in order to ask for email and name. But I am looking for a way to pass a email and skip this step.

Cheers

@ricardo9300 Try “uel” for user email parameter.

Hey @1engislam1,

Please share screenshot of the issue and the browser console errors.

Thanks,
Tommy

Hey @creative,

You can disable the Web SDK user sign in from the Zoom Web Portal Settings.

Thanks,
Tommy

Hey @ricardo9300,

Yes please try what @chad suggested.

&uel=base64EncodedEmail

Base64encode here.

Thanks,
Tommy

Tks Chad, Now I am waiting my client start a webinair in order to test it.

Regarding this, is there a way to create a webinair without a paid account?

Trying to use iframe to embed a meeting with the password included.

$src = “https://zoom.us/wc/join/xxx58840939?pwd=xxxhTG9SZko0V1VWbWVheG1UcU9FUT09

UPDATE: $src is now "https://zoom.us/wc/xxx58840939/join?track_id=&jmf_code=&meeting_result=&wpk=xxxk494114b903de9e1b95a75e7664cf2476"."&pwd=xxxhTG9SZko0V1VWbWVheG1UcU9FUT09

and then the corresponding html to use $src:

image

The frame is opening fine but, it doesn’t actually join the meeting. It leaves me on the Zoom page to enter password and name. Can’t I get it to just drop into the meeting? If so, what am I missing?

UPDATE: If you are logged into your personal zoom account, then it drops you on the entry portal with the password filled in and you just need to click Join. I just need Join to be automatic. …getting close

Thank you in advance for your help!
Bryan

1 Like

HI, I’m using the iframe to embed a zoom meeting !
It worked fine days ago without any zoom login .
But now, It require zoom account login first.
Is that option can be disable?

@tommy, @chad

Hi Guys,

Unfortunately, the parameter eul didn’t work for a Webinar.

Iframe:
< iframe
src=“https://zoom.us/wc/91687783953/join?prefer=0&un=UmljYXJkbw==&uel=cmljYXJkbzkzMDBAZ21haWwuY29t
frameborder=“0”
sandbox=“allow-same-origin allow-scripts allow-forms”
allow=“autoplay; microphone; camera; fullscreen” class=“c-ifram-zoom”>
< /iframe>

The website is running under an https protocol.
Here is the website webpage: https://stg-cd.sanoficonecta.com.br/eventos/telemedicina-aplicada-a-pratica-clinica-test

There are also a few errors showing on the console

can you check that?

Hi Guy @tommy and @chad

I just noticed that I am using the parameter prefer=0, I will test it again. Sorry about that.

Hi @tommy, @chad,

We are using webinars and embedding them on our website using the iframe.

Up until yesterday this was working well.

Now we are getting a “User email is required. (300)” error.

We are embedding the email using the uel parameter

https://zoom.us/wc/<%=videoId %>/join?prefer=1&un=<%= first_name_base64 %>&uel=<%= email_base_64 %>

Any advice?

Hi, @tommy, @studio-woburn

I did a test today and I’ve got this (it’s also a webinar):

you can see that I’ve printed out on my console the URL which I am setting on Iframe src.

FWIW we believe this is a new bug with zoom which started sometime over the weekend: Web client has stopped working when embedded in an IFRAME

Hi @flippyhead

Same problem with @ricardo9300.
Do you have any updates?
Thanks

We solved it here Zoom Web Client Iframe Integration insecure http redirect?

I am encountering the same issue. The WC just doesn’t open in the iframe…UNTIL…you open the WC in a separate window in the browser (just use whatever url you were using in the iframe). Once you have opened the WC in a separate window, you can close it. Then the iframe link starts working.

Bizarre…obviously a problem. But, that is what I have found… I am out here searching for a better workaround or a solution. I would be curious to know if this workaround works for anyone else.

Thanks, Bryan

Hi @tommy
Is there any other alternative instead ‘&uel=base64EncodedEmail’?

I’m trying to authenticate without e-mail information but I’m facing the same impeditive.
I think there is a relation with this issue with ‘https’.

Tks.

How did you acheive it… can you share please