Enabling Developer Tools in Linux

At some point recently Zoom Apps appeared in Zoom for Linux. Oddly though, there is no specific mention of support for Zoom Apps in the Linux release notes, just references to specific aspects of the UI presentation.

I have been able to create an app, register it in the Marketplace, install it in Zoom for Linux, and open it, however I can’t figure out how to enable the developer tools in the webview. This page describes how to do it on Microsoft Windows and Mac OS X:

I have tried adding the INI fragment for Windows to ~/.config/zoomus.conf and restarting, but this seems to have no effect. I have tried right clicking on the app pane, but no menu comes up. Perhaps that is not how you open the developer tools. The documentation above does not actually say how to do it.

I should also note that if I run strings on /opt/zoom/zoom, browser.native.interface is one of the strings which comes up, so the settings seems to exist in Zoom for Linux.

Thanks for posting in the Zoom Developer Forum. I wasn’t aware that Zoom Apps were available on Zoom for Linux, so I’ll need to verify this and get back to you. Have you tried executing the following command in the terminal as a test?

defaults write ZoomChat webview.context.menu true