Error 443 in curl when calling API

Good Morning.
First all, If there is an error in my writing, please excuse me but English is not my native language.

I’m a bit new to using the zoom API and am having a hard time executing API calls from the production server.
Locally I have no difficulties and I get a response. But when executing them from the server, yes.

Specifically, the error I receive from CURL is this:
‘Unknown SSL protocol error in connection to

The code currently is like this:

$token = $this->getToken();

        $header = array(
            'authorization: Bearer '.$token,
            'content-type: application/json'

        $options = array(
            CURLOPT_URL => $url,
            CURLOPT_RETURNTRANSFER => true,
            CURLOPT_ENCODING => "",
            CURLOPT_MAXREDIRS => 10,
            CURLOPT_TIMEOUT => 30,
            CURLOPT_HTTPHEADER => $header

        $curl = curl_init();
        curl_setopt_array($curl, $options);
        $response = curl_exec($curl);
        $curl_error = curl_error($curl);


        if ($curl_error){
            $salida['flagerror'] = 1;
            $salida['errormsg'] = $curl_error;
        } else {
            $salida['flagerror'] = 0;
            $salida['errormsg'] = '';
        $salida['response'] = $response;
        return $salida;

The endpoint I am trying to call is

The token obtained is fine.
I have consulted in the forums about the error 443 and among the answers they suggest setting the value CURL_SSL_VERSION_SSLv3 in SSLVersion but the result is the same.

I am accessing the API using JWT App that I have previously created in my account following the steps of the QuickStart.

In $salida I save the response I get, and when examining the error it indicates the error I mentioned above.

If it is not too much trouble, I would like to know if you can guide me what could be the problem.
Thanks a lot,

Best regards

Greetings @marcelocuadrado

Could you test making that same call from inside of Postman (to isolate if it is an environmental issue with your PHP server’s SSL or not)?

If it works in Postman, then it is an environmental issue.
If it does not work in Postman, please share the request, complete with headers, here (hide/obfuscate the access_token from the “Authorization” header though please, and remove any other identifying data before posting).

Thanks for answer so soon.
I have done a test from postman and I get a response:

What could it be? :frowning:

best regards

PS: this test with postman I have done both locally and from the production server.
And in both I receive a reply.

Hey @marcelocuadrado,

Are you able to request other (non Zoom) APIs from your server?

I wonder if it is a firewall issue, or your CURL command has a bug?


Hi @tommy
Short answer: Yes.
On the server we have an automatic process that consumes other APIs and is operating without problems.

best regards,

1 Like

Thanks @marcelocuadrado,

Are you using TLS 1.2 on your production server?


Good morning, I apologize for the delay in responding.

My coworker and I are reviewing the server settings in order to check the status of the tls and ssl connection.

Best regards,

1 Like

Thanks, let us know what you find! :slight_smile:


hay marcelo, i am getting error same , how you fix that error??


Hey @rizki.troy,

Can you help isolate the issue by following my above posts?


hy @tommy

I can access some APIs but when trying to access zoom API . I get an error “443”

even though I already made a new connection tls 1.2 in windows

Thanks your help


Hey @rizki.troy,

Can you post your request url, body / headers, and response body / errors so I can reproduce the issue?


Hy @tommy

thats my code


Good Morning,
Please excuse the delay in responding. We were busy.
We have reviewed the server, and we found that something is blocking port 443. As soon as we try to enable the port, it immediately blocks again.
We have not been able to determine which application will be affecting there. Unfortunately it is a server of our client that we cannot touch much.
As times are pressing, we have chosen to move the system we are developing to another server that we can control.
On our own servers the system operates without problems. We know that this does not solve the problem itself, but we had to move forward with the project in some way.

Best Regards,

1 Like

Hey @rizki.troy,

Which API endpoint are you calling??


Hey @marcelocuadrado,

Thanks for sharing an update! Glad to hear unblocking / using a server that does not block 443 fixes the issue.


Hey @tommy
Sorry too late response

I’m trying user with url


i’m trying to create meeting with url

to now i’am get error same, im already to set TLS 1.2 and 3.o


Hey @rizki.troy,

Have you tried what @marcelocuadrado suggested?