Unknown SSL protocol error in connection to api.zoom.us:443

Description
Unable to make an API call using curl PHP

Error
Unknown SSL protocol error in connection to api.zoom.us:443

Which App Type (OAuth / Chatbot / JWT / Webhook)?
Using JWT token in the curl API call.

Which Endpoint/s?
https://api.zoom.us/v2/users/{userID}/meetings

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Below is the gitlab link to sample code:
    curl_example.php · master · Mudassir Khan / Zoom Issue Curl API · GitLab
  2. Below is the error
    image

Additional context
I’m able to get the data using the Postman but not able to get any data using curl PHP locally.

Hi @khanmdmudassir,

If this request is working for you in Postman, this is likely an issue with your PHP server configuration.

Please check out these threads and let me know if they help:
https://devforum.zoom.us/search?q=Unknown%20SSL%20protocol%20error

Best,
Will

I agree on the PHP configuration part. But I’m using the same PHP script to call other third party APIs like TalkJS, its working for them but doesn’t work for Zoom API calls.

Is there a special header or curl parameter we need to include for API call from Zoom ? I will try to run the script under SSL and let you know if it works.

Also I did checked out the relevant post in the devform but there isn’t solution available.

Hi @khanmdmudassir,

Have you tried exporting the code snippet generated by Postman in PHP, to compare against how you’re calling the API in your PHP script?
image

This might help expose a missing header or something else that could be different between these environments.

Let me know how this goes!
Will

Hi @will.zoom,

Thanks for your inputs, but I tried the code from Postman as well and it didn’t work

The API call worked when I had tested my code on production server under SSL certified domain.

But it does worked with non SSL environment/Local environment. Even the local certificate isn’t working in this case.

I need to get the API call working in local environment for development purpose.

Hi @khanmdmudassir,

Thanks for clarifying—since this is an SSL related error and your request works in Postman, it sounds like this is related to your environments and their certs, rather than the Zoom API. Have you tried checking StackOverflow for similar errors?

Thanks,
Will