Error: "Password can only have a maximum 10 characters." on `/meetings/{meeting_uuid}/recordings/settings`

I am trying to set a password for a recording using

When calling PATCH /meetings/{m.uuid}/recordings/settings, with a {"password": "..."} I get the following response:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <message>Validation Failed.</message>
        <message>Password provided does not match the password requirement settings set for this account. The password
            must follow these rules: [Password can only have a maximum 10 characters.].

However, I do not know about such a limit (password can be longer than 10 chars through the UI).

(Auth: JWT)

See also: Bug? Max Length Password on Recurring Meetings with No Fixed Time (v2)

attn: @tommy

Please advice. Thank you!

cc: @shrijana.g
:slight_smile: :slight_smile: :slight_smile: :slight_smile:

Hi @UdiO,

In your accounts settings, can you double check the requirements outlined under password settings? You can follow these steps:

If this is checked off in the UI, it will apply to your API requests as well.



How is this related to my question?
I am setting a password for a recording.
Through the UI it works.
The error is:
Password can only have a maximum 10 characters.

Please advice.

Hi @UdiO,

Apologies for any confusion—my initial hunch was that you were running into this error due to some settings on your account that were overriding the API request. However, it sounds like this is not the case.

Can you please open up a request with us here, including the password you’re attempting to pass, and your account ID/email? This will help us to take a closer look.


I have opened a ticket, #12953225 , feel free to follow along.
I believe any legal password > 10 chars will trigger this.

Thanks, @UdiO — our team will be in touch shortly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.