Error while starting zoom meeting without login in android sdk

While starting zoom meeting in the following , it show waiting for host to start the meeting. But how is this possible? I am the host and I am the one trying to start the meeting. What the solution for this?
I have tried the same in latest zoom sample project code for android and still the same problem.

MeetingService meetingService = mZoomSDK.getMeetingService();
StartMeetingOptions opts = ZoomMeetingUISettingHelper.getStartMeetingOptions();

    StartMeetingParamsWithoutLogin params = new StartMeetingParamsWithoutLogin();
    params.userId = userId;
    params.userType = MeetingService.USER_TYPE_API_USER;
    params.displayName = DISPLAY_NAME;
    params.zoomAccessToken = zak;
    params.meetingNo = meetingNo;
    meetingService.startMeetingWithParams(context, params, opts);

Hi @winualldevs, thanks for the post.

If you are trying to start a meeting as an API user and are being put on that waiting screen, it could mean that you are not using the ZAK associated with the meeting’s host. Please verify that you are using the correct user to start the meeting.

Thanks!

I am using apikey, apisecret and meeting number to create ZAK. If this is wrong procedure then please guide me through the correct procedure to create ZAK. It will be very helpful if you share an example, which could demonstrate me how to create it.

Hi @winualldevs,

Based on the code you have provided, you are probably retrieving a ZAK correctly. If you were not, you would be seeing the SDK produce an error.

The problem you are seeing seems to stem from using the ZAK of the wrong user. So if user 1 is the host of the meeting and you retrieve the ZAK of user 2 who is a regular attendee, you may not be able to join the meeting with their ZAK depending on the meeting’s settings.

For more information on how to verify this, see our users API docs and the #zoom-api category of the devforum.

After you have confirmed that your usage of the API is correct and you are using the ZAK of the user who is the host of the meeting, let me know if you are still seeing the same behavior.

Thanks!

In my case showing Meeting failed with error code 9:
what is the reason for that and what is meeting number and how to retrieve it(Currently i am passing random number).
and as user id i am using my registered email id.

Hi @nitin.thakor, thanks for the post.

According to our error code documentation, this means that the meeting you are trying to start/join does not exist.

When you say that you are passing in a random number, are you referring to the meeting number? Unless you are a logged in user starting an instant meeting, you must always provide a valid meeting number when starting or joining a meeting.

Thanks!