ErrorType=2003,Error Details=16 followed by Error Type=2008,Error Details=16 iOS


I looked through all the forums and tried updating the jwt key multiple times and pasting it in the appDelegate.h under #define kAppToken. When I execute the code and build the app on my iphone and create a new session, the app starts the video and quits with the error provided in the title. This is using the VideoSDK for the ios v1.6.1. This is payload I am using for creating the JWT token. This is me trying to run the quickStart Sample app
“app_key”: “xxxx”,
“version”: 1,
“tpc”: “myName”,


Thank you for posting in the Zoom Developer Forum – happy to help! As a start, can you confirm whether you’ve validated that the JWT was generated correctly? If not, you can do so using

Hello Donte, the token was accurately generated One things I noticed in release notes is that the ios latest version is compatible with XCODE 12. I am using XCODE 14 to build. Do you think that matters?

@vishnu.vithala ,

Thank you for your response. I have seen reports of XCODE 14 causing an issue with Are you seeing the same result when using a different session name than in the JWT token? For the token, as a test, can you try the session name with the value “myName” when creating or joining a session?

Hello Donte, I tried with a different name and get the same error. I changed the " app_key" to appKey and now I am getting a different error
2023-01-18 21:53:31.691495-0800 ZoomVideoSample[7421:390880] ErrorType========2014, Parameter error when joining the session

2023-01-18 21:53:31.691798-0800 ZoomVideoSample[7421:390880] ErrorDetails========5003

2023-01-18 21:53:31.710638-0800 ZoomVideoSample[7421:390880] ErrorType========2008, Disconnecting session…

@vishnu.vithala ,
Strange! It looks like the “user_identity” property is optional, can you try to generate the JWT without it? I just tested using XCODE 14.2 to build on my end and was able to Join the session on my IOS device. So I do not think the “user_identity” or the app_key property is the source of the problem. Here is a screenshot of the python script I used to generate the JWT along with my device screen recording.

Device Screen Recording :

Re-tried it with the same parameters that you have in your script in No avail. Same Error(2003, Error Details=16).
Be sure to remove PII before posting on the Zoom Developer Forum.
Screenshot :

Thank you for the screenshot, @vishnu.vithala ! Can you share whether JWT.IO shows "Signature Verified " when you enter the value for your secret?

Be sure to remove PII before posting on the Zoom Developer Forum.
Screenshot :

@vishnu.vithala ,

What language are you using to generate the signature? Please share a snippet as I think the issue is the script used to generate the signature.

Not sure which language you are referring to.I am using the JWT.IO to generate the signature then I just copy paste it into XCode. As shown in the screenshot. I just noticed the “Enter your VSDK here without wrapping it” in red. I was not populating that before. Let me try that and give it a shot.

That worked! I was not putting in my secret key

Awesome @vishnu.vithala! Glad to hear that helped resolve the behavior you were seeing and thanks for sharing this update with us!

Hello Donte, I have a new problem wherein I am not able to trigger this portion of the code in the iOS starter code.

#pragma mark **- audio rawdata delegate -**

- (**void**)onMixedAudioRawDataReceived:(ZoomVideoSDKAudioRawData *)rawData


NSLog(@"onMixedAudioRawDataReceived %@", rawData);


- (**void**)onOneWayAudioRawDataReceived:(ZoomVideoSDKAudioRawData *)rawData user:(ZoomVideoSDKUser *)user


NSLog(@"onOneWayAudioRawDataReceived %@", rawData);}

- (**void**)onSharedAudioRawDataReceived:(ZoomVideoSDKAudioRawData *)rawData


NSLog(@"onSharedAudioRawDataReceived %@", rawData);


The error message “Authentication failed with status code 401” indicates that the authentication process for your app has failed. This can be caused by a variety of issues, including incorrect or expired JWT tokens, incorrect app keys or secret keys, or network connectivity issues.

Based on the information provided, it seems that you have already tried updating the JWT key multiple times and pasting it in the appropriate location in your code. However, it is possible that there is an error in the way you are generating the JWT token, or that the token has expired.

To troubleshoot this issue, you may want to try the following steps:

Double-check that the app key and secret key you are using are correct and match those provided by the VideoSDK.

Make sure that the system time on your device is accurate, as an incorrect time can cause issues with JWT token validation.

Try generating a new JWT token with a longer expiration time and see if that resolves the issue.

Check the network connectivity on your device and ensure that it is not being blocked by a firewall or other security software.

If none of these steps resolves the issue, you may want to reach out to the support team for the VideoSDK for further assistance.

Rachel Gomez