Fields missing from Participants/Registrants API

I’m trying to get the same participant fields for past webinars from a Zoom API Endpoint that I can currently get from the manual CSV download.
In particular the “Time In Session” field, but also “Country/Region Name”.

Whether I use the Participants or the Registrants endpoints there is no field for the “Time in Session” field.
“Country/Region Name” is coming through blank

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Which Endpoint/s?
I have mainly tried
but also

Additional context
The fields which come through in the past webinars/participants reports are:
User Name
First Name
Last Name
Job Title
Registration Time
Approval Status
Join Time
Leave Time
Time in Session (minutes)

These fields do come through for the meetings endpoint (/v2/report/meetings/9071401427/participants) - which seems a little quirky given that meetings are free to run.

Ideally all I want is a JSON file that holds the registrant ID, the Time in Session and the Country.

Thanks for any help

Hey @Coriel-11,

Thank you for reaching out to the Zoom Developer Forum. Please try using the Get Meeting Participant Reports API for the duration and registrant ID:

You can also get the location and registrant ID from the List Meeting Participants Dashboard API

Let me know if that helps.


Hi @MaxM

Unfortunately the "“Get Meeting Reports API” doesn’t work for webinars, only for normal meetings. I just get an error status. Same with the “List Meeting Participants Dashboard API”

Thank-you for taking the time to help though. Do you have any other ideas that might help?


Hey @Coriel-11,

My apologies for linking the wrong API there but we also have the Get Webinar Participant Reports API as well as the Get Webinar Participants Dashboard API.

I hope that helps!


Thanks again @MaxM.

The first one works and gives me the duration data - thank you so much.

For the second one, though, I’m getting an error status when I run the one on the link (
/metrics/webinars/{webinarId}/participants). So I tried the following variations. For each I got a 200 status, but no data at all (despite using the same webinarIDs as for the 1st one):

  • /metrics/past_webinars/{webinarId}/participants
  • /webinars/{webinarId}/participants
  • /metrics/{webinarId}/participants

Any more ideas?

Thanks again for the first one.


Hey @Coriel-11,

When you’re calling the /metrics endpoints, are you including the type=past query parameter?


Hi @will.zoom ,

A-ha! That’s it. I hadn’t been doing that (took me a while to figure out you just have to add “?type=past” onto the end of the endpoint url, and now it’s actually working!!). Thank you so much.


Awesome, glad that did the trick. :slight_smile: