Gallery View in Webinars is not working

In the latest SDK version 1.9.5, there is this bullet point.

Support for reordering gallery and speaker view within webinars.

Gallery view is still unavailable to participants in a webinar using the latest SDK.

Here is a screen shot of us using the app to try and push gallery view to the participants of a webinar in the Web Client.

This was tested using Chrome.

Adding some more details from our testing. We turned on video to make the screenshot more apparent. In the Webinar view, all that shows up is the ribbon in speaker view.

I noticed that when joining a webinar in the SDK, the “View” option button in the top right shows up on load but quickly disappears. I’m not sure if this is a bug or a issue with my setup. Any advice?

Hey @ckarpyszyn,

Thank you for reaching out to the Zoom Developer Forum. Just to clarify, you’re only seeing this behavior with Webinars? Are you specifically referring to participants or are host/panelists missing it too?

Thanks,
Max

Hi Max, I’ll update with a video in a bit but yes, as a participant.

Basically, as a participant when I join a webinar, I see a popup that disappears quickly saying that I “Can now view in Gallery view”. But there is no way to change my view.

Gallery View will work if the host forces “Force Viewing Mode”. But this will only work for participants already in the webinar. If more people join they will see speaker view until the host toggles the force viewing mode option.

Hey @ckarpyszyn,

Interesting, I appreciate the additional information. If you want to send the video to developersupport@zoom.us I can follow up with you there and engage our engineering team if necessary.

We also recently released v1.9.6 so you can test with that, if possible.

Thanks,
Max

I’ll test with 1.9.6 and then fire over the video.

Hey @ckarpyszyn,

Excellent, thank you! I’ll keep an eye out for the ticket.

Thanks,
Max

1 Like