Get Meeting Participant Reports Return 400 Bad Request

Description
Get the Meeting Participant from the desktop app not working.
Manually I succeed, but from the Program return an error

I do as the API Document said

Did I miss Something???

I see in the manually I can choose a date for that meet was

Error
The remote server returned an error: (400) Bad Request.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
OAuth2, already created develop client. already got the token and refresh token.

Which Endpoint/s?
My desktop client

How To Reproduce (If applicable)
Steps to reproduce the behavior:
I work with PowerShell

That what I send

$url =“https://api.zoom.us/v2/report/meetings/$MeetID/participants

$header = @{}
$header.Add(“Content-Type”,“application/json; charset=utf8”)
header.Add("Authorization","Bearer ($accessToken)")

Invoke-RestMethod -Method Get -uri $url -Headers $header

Screenshots (If applicable)


If applicable, add screenshots to help explain your problem.

Addition Information

I am using another User, an Education License user

Hi @asaf12100,

Thanks for reaching out about this, and happy to help.

To clarify, does this request work when you try from your console or something like Postman? Is it only when running your script that you run into this issue?

If you’re using PowerShell, can you try the following:

$headers = New-Object "System.Collections.Generic.Dictionary[[String],[String]]"
$headers.Add("Authorization", "Bearer {token}")

$response = Invoke-RestMethod 'https://api.zoom.us/v2/report/meetings/{meetinId}/participants' -Method 'GET' -Headers $headers -Body $body
$response | ConvertTo-Json

Let me know—thanks!
Will

Still error 400

What I should put in body??
can you give me example

$meetinId=“86400933558”
$headers = New-Object “System.Collections.Generic.Dictionary[[String],[String]]”
headers.Add("Authorization", "Bearer ($accessToken)")

response = Invoke-RestMethod "https://api.zoom.us/v2/report/meetings/($meetinId)/participants" -Method ‘GET’ -Headers $headers -Body $body
$response | ConvertTo-Json

Hi @asaf12100,

This request does not include a body—were you able to test in Postman?

Thanks,
Will

in PowerShell only
Now I will try in Postman,
I will give you the result


But I got manually download the report,
And there no Report on my bot dev page

Hey @asaf12100,

Thank you for the update. Make sure that you are selecting the report:read:admin scope by scrolling down on the left hand side of the Add Scopes dialog so that you can see the Report category.

Then, you’ll want to reinstall the application for the scopes to take effect.

I hope that helps! Let me know if you have any questions.

Thanks,
Max

Thanks, @MaxM.
But I don’t see these Scopes
I am using Education User, log in with SSO.
On the bot scopes, I post in the last post what scopes I have.
there anything I can/Should do to get these

Hey, ty for restore the Topic
What am I doing wrong? Why can’t I have the report?

Hey @asaf12100,

Thank you for the update. Please make sure that you are using an account-level oauth app. Some scopes won’t be available for a user-level oauth app.

Let me know if that helps.

Thanks,
Max

How Do I do that???
If I am using Edu Account, I just one of many Users…
What it means account level and not user level?

Hey @asaf12100,

Good question! As the report:read:admin is an administrator level scope, this means that you will need an account-level app. Whereas a user-level app is installed by each user, an account-level app exists on the entire account and has higher access potential than a user-level app.

You can learn more about account-level versus user managed apps here.

I hope that helps! Let me know if you have any questions.

Thanks,
Max

Yes, that answers my question.
So it means, Account it like the Out government Education service
who buy the licenses for each school,

And the User: are the teachers who use the license.
so it means I cannot do use the “report:read:admin” scope, because I’m not Account-level

Hey @asaf12100,

Thank you for your question. You can create an account-level app but it will need to be installed on the account by an administrator.

Thanks,
Max

It won’t be an option cause I Don’t know who is he/she
it hard to explain
but thank you very much!!!
I will do that manully

Hey @asaf12100,

I’m happy to hear that answered your question! Feel free to reach out if you encounter any further issues or questions.

Thanks,
Max